PDA

View Full Version : Installing Boost properly



hitman666
02-Jul-2014, 11:36
Hi!

Could anyone suggest me how to get boost installed and run properly with its dependencies?

I am trying to compile a c++ driver for cassandra ( https://github.com/datastax/cpp-driver/ ) which requires boost.

I have already installed boost-devel 1.55.0 via zypper. The installation wasn't ideal since I had two options as you can see in the image (http://hpics.li/f6eb3d3). When I try to "make", the processus exits with the following message:

make[2]: *** No rule to make target '/usr/lib64/libboost_system.so', needed by 'libcql.so.0.7.0'. Stop.
make[1]: *** [CMakeFiles/cql.dir/all] Error 2
make: *** [all] Error 2


I am using Suse Linux Enterprise Server 11 SP3 X86_64.

Thanks for the help!

mikewillis
02-Jul-2014, 12:43
I have already installed boost-devel 1.55.0 via zypper. The installation wasn't ideal since I had two options as you can see in the image (http://hpics.li/f6eb3d3).

That image shows that you chose to install boost-devel with it's dependencies unmet. Additionally the rpm you've installed appears to be for FedoraCore 21 (the name includes fc21). So that it hasn't worked as you'd like is not at all surprising.

There is a boost-devel package that can be installs on SLES 11 SP3 in the SLE SDK. The version for use with SLES 11 SP3 can be obtained from
https://download.suse.com/Download?buildid=hF8sRGTVC04~

Anyone else reading this in the future whilst looking for boost-devel and not using SLES 11 SP3 might find the version of the SDK they need by looking at https://forums.suse.com/content.php?121-SUSE-Linux-Enterprise-SDK-downloads

hitman666
02-Jul-2014, 12:52
Thanks for replying.


There is a boost-devel package that can be installs on SLES 11 SP3 in the SLE SDK. The version for use with SLES 11 SP3 can be obtained from
https://download.suse.com/Download?buildid=hF8sRGTVC04~
All I can see is .iso files for downloading.

I had mistakenly created a post in a wrong section (https://forums.opensuse.org/showthread.php/499305-Install-Boost-properly?p=2652056#post2652056), if you don't mind having a look you may understand better where I am upto!

mikewillis
02-Jul-2014, 13:11
All I can see is .iso files for downloading.

Yep, those are the isos for the SDK. Download the appropriate DVD1 iso, use YaST to add it as a repository, run


$ zypper refresh
$ zypper in boost-devel

If you haven't done so already, remove that boost-devel package you've already installed with

$ rpm -e boost-devel

hitman666
02-Jul-2014, 13:57
Thanks mikewillis!