PDA

View Full Version : SMT Error while fetching rubygem-polkit-debuginfo



didiw23
07-Jul-2014, 15:21
Hello,

I am running SMT to get the updates for SLES from nu.novell.com. Whenever the software tries to fetch

https://nu.novell.com/repo/$RCE/SLES11-SP1-Pool/sle-11-x86_64/rpm/x86_64/rubygem-polkit-debuginfo-0.1.2-0.3.4.x86_64.rpm
it receives the error

504 Gateway timeout
I don't really need this package, so either the solution could be to disable fetching this package or to correct the error.
There is no problem with other packages, just this one.
Does anybody have any idea, what I can do to get rid of this problem.

Regards

Dieter

jmozdzen
08-Jul-2014, 11:07
Hi Dieter,

do you have any proxies in the path from your SMT server to SUSE's repository? What happens if you issue an explicit fetch via "wget" or a browser (you'll need to specify your "mirroring credentials" for this)?

I've seen no other reports about this error - which makes it likely that the cause is on your side of the connection... but only "likely", not forcibly so :)

Regards,
Jens

didiw23
08-Jul-2014, 16:38
Hi Jens,


Hi Dieter,

do you have any proxies in the path from your SMT server to SUSE's repository? What happens if you issue an explicit fetch via "wget" or a browser (you'll need to specify your "mirroring credentials" for this)?

yes there is a http proxy between us and the SUSE repository.

I just ran the command

wget https://nu.novell.com/repo/$RCE/SLES11-SP1-Pool/sle-11-x86_64/rpm/x86_64/rubygem-polkit-debuginfo-0.1.2-0.3.4.x86_64.rpm
The result was

Proxy request sent, awaiting response... 404 Not Found
2014-07-08 16:29:18 ERROR 404: Not Found.
Ok, I understand, that this rpm does not exist any more. But why is SMT still trying to fetch it and not a possible newer version?


I've seen no other reports about this error - which makes it likely that the cause is on your side of the connection... but only "likely", not forcibly so :)

Regards,
Jens
Is there a way I can tell SMT not to try fetching this package any more?

Regards

jmozdzen
08-Jul-2014, 17:08
Hi Dieter,

Hi Jens,



yes there is a http proxy between us and the SUSE repository.

maybe the result of a previous call (that actually failed) got cached...


I just ran the command

wget https://nu.novell.com/repo/$RCE/SLES11-SP1-Pool/sle-11-x86_64/rpm/x86_64/rubygem-polkit-debuginfo-0.1.2-0.3.4.x86_64.rpm
The result was

Proxy request sent, awaiting response... 404 Not Found
2014-07-08 16:29:18 ERROR 404: Not Found.
Ok, I understand, that this rpm does not exist any more. But why is SMT still trying to fetch it and not a possible newer version?

Hm, maybe you got tricked by the shell, which tried to substitute part of the line by the content of the variable "RCE"? Please enclose the URL in single quotes and retry. I do expect that you'll receive some "auth required" response then, you'll have to add the --http-user and --http-password options to specify your mirror credentials.

With regards,
Jens

didiw23
15-Jul-2014, 16:40
Hi Jens,

Hi Dieter,


maybe the result of a previous call (that actually failed) got cached...



Hm, maybe you got tricked by the shell, which tried to substitute part of the line by the content of the variable "RCE"? Please enclose the URL in single quotes and retry. I do expect that you'll receive some "auth required" response then, you'll have to add the --http-user and --http-password options to specify your mirror credentials.

With regards,
Jens
You are completely right. I did not notice the $ in the URL, though I had already seen it. And I get the
401 Unauthorized, though I used the values from
NUUser = nnnnnn
NUPass = xxxxxxxxxxin /etc/smt.conf. Are those the right user and passwords or where do I find them?

Regards
Dieter

jmozdzen
15-Jul-2014, 18:24
Hi Dieter,

And I get the
401 Unauthorized, though I used the values from
NUUser = nnnnnn
NUPass = xxxxxxxxxxin /etc/smt.conf. Are those the right user and passwords or where do I find them?

Regards
Dieter

those are the ones I'd have used, too. Interestingly, I currently receive "504 Gateway Timeout" with the URL you used :( Maybe some hickup of the SUSE server, or because that code level now is out of support?

Regards,
Jens

didiw23
17-Jul-2014, 16:14
Hello,

Hi Dieter,


those are the ones I'd have used, too. Interestingly, I currently receive "504 Gateway Timeout" with the URL you used :( Maybe some hickup of the SUSE server, or because that code level now is out of support?

Regards,
Jens

is somebody from SuSE/Novell reading this and can help?

Regards

Dieter

smflood
17-Jul-2014, 16:46
On 17/07/2014 16:24, didiw23 wrote:

> is somebody from SuSE/Novell reading this and can help?

These forums are not officially monitored by SUSE/Novell. If you want
their attention you will need to open a Service Request.

HTH.
--
Simon
SUSE Knowledge Partner

------------------------------------------------------------------------
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below. Thanks.
------------------------------------------------------------------------