PDA

View Full Version : missing libtinfo.so.5 in sled11sp3 when installing zsnes



ofvergara
24-Sep-2014, 00:22
hello,
due to a $%& i did, i trashed a perfectly working sled11sp2 installation with all the programs and settings i like and had to install the newer sled11sp3.
however, when trying to recover and reinstall programs, i have found out that the older versions i used are gone, and only newer (and often, incompatible versions for sled) are available.

one of this, is the supernintendo emulator zsnes.
the current version in software.opensuse.org is zsnes 1.51

i downloaded it and tried to install, and complains about this:
sled11sp3:/home/omar/bin/linux-install/sled11sp3 # rpm -Uvh zsnes-1.51-9.146.i586.rpm
error: Failed dependencies:
libtinfo.so.5 is needed by zsnes-1.51-9.146.i586

i tried the following solution found at http://forums.opensuse.org/showthread.php/446927-missing-library-libtinfo-so-5 , however, that didn't work either.

the last time i tried solving the dependencies manually (ncurses and other sensitive files from opensuse) and when forcing the installation of zsnes, i ended up reinstalling sled11sp3 again since it crashed the system.

where can i get this file in order to install this emulator?
thank you.

malcolmlewis
24-Sep-2014, 16:30
On Tue 23 Sep 2014 11:24:02 PM CDT, ofvergara wrote:


hello,
due to a $%& i did, i trashed a perfectly working sled11sp2 installation
with all the programs and settings i like and had to install the newer
sled11sp3.
however, when trying to recover and reinstall programs, i have found out
that the older versions i used are gone, and only newer (and often,
incompatible versions for sled) are available.

one of this, is the supernintendo emulator zsnes.
the current version in software.opensuse.org is zsnes 1.51

i downloaded it and tried to install, and complains about this:
*sled11sp3:/home/omar/bin/linux-install/sled11sp3 #* rpm -Uvh
zsnes-1.51-9.146.i586.rpm
error: Failed dependencies:
libtinfo.so.5 is needed by zsnes-1.51-9.146.i586

i tried the following solution found at
http://forums.opensuse.org/showthread.php/446927-missing-library-libtinfo-so-5
, however, that didn't work either.

the last time i tried solving the dependencies manually (ncurses and
other sensitive files from opensuse) and when forcing the installation
of zsnes, i ended up reinstalling sled11sp3 again since it crashed the
system.

where can i get this file in order to install this emulator?
thank you.




Hi
Where did you get the emulator from?

On OBS, in the emulators repository, I see it's missing some
dependencies, contact the Maintainer and ask to fix...
https://build.opensuse.org/package/show?project=Emulators&package=zsnes

https://build.opensuse.org/package/users/Emulators/zsnes

You shouldn't have to use anything built against an openSUSE version,
build it against SLE always...

--
Cheers Malcolm °¿° LFCS, SUSE Knowledge Partner (Linux Counter #276890)
openSUSE 13.1 (Bottle) (x86_64) GNOME 3.10.1 Kernel 3.11.10-21-desktop
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below... Thanks!

ofvergara
25-Sep-2014, 23:52
Hi Malcolm,
as a matter of fact, I contacted Stefan yesterday and he managed to build a wonderful version of zsnes with no dependencies for sled11sp3!!
i consider myself a very good pilot-wing player, and it played very well.

my first impression was, it felt a little bit harder than before (maybe because i haven't played since i had to reinstall sled11sp3 more than a month ago) and at the beginning the joystick was misbehaving, but when i was regaining my skills the game started to behave properly.

he has uploaded znes to the repository and it is available here for download:
http://download.opensuse.org/repositories/Emulators/SLE_11_SP3/i586/

thanks for the hint!!
cheers.