PDA

View Full Version : zipl.conf missing from /etc/ in SLES 12 install



x0500hl
17-Nov-2014, 15:34
I am installing SLES 12 and need to modify zipl.conf like I did with previous versions of SLES and found that /etc does not contain file zipl.conf.

Specifically, I need to add 'vmpoff=LOGOFF' to the parameters so that Linux will logoff the z/VM guest when it terminates.

I've searched the internet and several of the SLES 12 manuals and can only find entries similar to 'modify /etc/zipl.conf ...'. I searched SLES 12 for 'zipl.conf' and found a sample file. Can I simply copy /usr/share/doc/packages/s390-tools/zipl.conf.sample to /etc/zipl.conf and start from there? Is there a way to display the zipl options in effect to verify that the sample matches what is running?

Thanks,


Harley

x0500hl
17-Nov-2014, 15:52
Update

I shutdown the SLES 12 system and booted it by logging onto the virtual guest so that I could monitor the console (as opposed to issuing the XAUTOLOG command to boot). The menu that was displayed does not match the menu as specified in /usr/share/doc/packages/s390-tools/zipl.conf.sample.

x0500hl
18-Nov-2014, 15:18
I should have done some more reading on this...

SUSE changed the boot process with SLES 12. It looks like the system doesn't use zipl (nor zipl.conf) any longer. Chapter 12 of the Administration Guide discusses the boot loader as being GRUB 2. There are new configuration files and a new script for generating the boot loader, grub2-mkconfig.