PDA

View Full Version : Gnome APPS Log Details



naren_bishayee
25-Nov-2014, 06:00
Hi All,

I'm using SLED12 x86_64 on my laptop. Previously I used SLED11 & didn't face such problem ::

Mainly two application's behaviour are are abnormal (some times).

Evolution :: to write a new mail (either Ctrl+N or 'New' from the Icon) does not work sometimes, on the taskbar it although shows the new Compose Mail window but it's not clickable, after 3-4 minutes later it'll display a popup window with 'Force to quit' and 'Wait' button from Evolution. After 3-4 times click the 'Wait' button, it display & active the Compose Mail window. If I click 'Force to quit' button then entire Evolution mail client close, which is normal, but after start the Mail client, it again shows the same thing (if again I would open a Compose Mail). But during this time other apps behaviour remain normal.


Rhythmbox :: Sometimes it quit, may be during playing the music from my Local Library or sometimes it quit If i would add some audio from my Local library to my playlist.

On the previous version of SLED11 I never faced such type of apps behaviour.

So, to solve this can any one tell me where are logs for those apps, so that if again that happens then I can post the log details.

Thanks

malcolmlewis
25-Nov-2014, 06:26
On Tue 25 Nov 2014 05:04:01 AM CST, naren bishayee wrote:


Hi All,

I'm using SLED12 x86_64 on my laptop. Previously I used SLED11 & didn't
face such problem ::

Mainly two application's behaviour are are abnormal (some times).

Evolution :: to write a new mail (either Ctrl+N or 'New' from the Icon)
does not work sometimes, on the taskbar it although shows the new
Compose Mail window but it's not clickable, after 3-4 minutes later
it'll display a popup window with 'Force to quit' and 'Wait' button from
Evolution. After 3-4 times click the 'Wait' button, it display & active
the Compose Mail window. If I click 'Force to quit' button then entire
Evolution mail client close, which is normal, but after start the Mail
client, it again shows the same thing (if again I would open a Compose
Mail). But during this time other apps behaviour remain normal.


Rhythmbox :: Sometimes it quit, may be during playing the music from my
Local Library or sometimes it quit If i would add some audio from my
Local library to my playlist.

On the previous version of SLED11 I never faced such type of apps
behaviour.

So, to solve this can any one tell me where are logs for those apps, so
that if again that happens then I can post the log details.

Thanks




Hi
Normally in those cases I open a terminal and run (as in start) the
application from the command line, else start the application with gdb;


gdb evolution
....
{gdb starting up}
.....
run <press enter>

The other one is using strace again from the command line in a terminal;


strace evolution



--
Cheers Malcolm °¿° LFCS, SUSE Knowledge Partner (Linux Counter #276890)
SUSE Linux Enterprise Desktop 12 GNOME 3.10.1 Kernel 3.12.28-4-default
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below... Thanks!

naren_bishayee
25-Nov-2014, 08:22
Hi Malcolm,

Thanks for those commands, I've already started the evolution with the 'strace' programe


strace -C -oevolution_log-25-NOV-2014 evolution

If it'll again happen, I'll send the log.

Thanks


Hi
Normally in those cases I open a terminal and run (as in start) the
application from the command line, else start the application with gdb;


gdb evolution
....
{gdb starting up}
.....
run <press enter>

The other one is using strace again from the command line in a terminal;


strace evolution



--
Cheers Malcolm °¿° LFCS, SUSE Knowledge Partner (Linux Counter #276890)
SUSE Linux Enterprise Desktop 12 GNOME 3.10.1 Kernel 3.12.28-4-default
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below... Thanks!

naren_bishayee
26-Nov-2014, 06:27
Hello All,

Can anyone tell me how to attach 60 MB file to forum.

last day Rhythmbox exit abnormaly, & I've grab the log details using 'strace', and now I need to post it to the forumn so that anyone can help me.
But the log file size is approx 60 MB & I can't attach it into forum.


Thanks

malcolmlewis
26-Nov-2014, 06:38
On Wed 26 Nov 2014 05:34:01 AM CST, naren bishayee wrote:


Hello All,

Can anyone tell me how to attach 60 MB file to forum.

last day Rhythmbox exit abnormaly, & I've grab the log details using
'strace', and now I need to post it to the forumn so that anyone can
help me.
But the log file size is approx 60 MB & I can't attach it into forum.


Thanks




Hi
If you look at the last part of the log, can you see it starting to
generate errors before it crashes?

--
Cheers Malcolm °¿° LFCS, SUSE Knowledge Partner (Linux Counter #276890)
SUSE Linux Enterprise Desktop 12 GNOME 3.10.1 Kernel 3.12.28-4-default
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below... Thanks!

naren_bishayee
26-Nov-2014, 06:59
Hello Malcolm,

I've two log files, first one genareted by the 'strace -o' and the second one actually was on the terminal 'strace -C', and I copied it to a file

Now, when the Rhythmbox terminated, on the terminal I've seen huge lines and I can only grab approx 500 lines. Bellow are last three lines from the strace terminal output ::


7fa84b024000-7fa84b025000 rw-p 00014000 00:20 4933 /lib64/libresolv-2.19.so
7fa84b025000-7fa84b027000 rw-p 00000000 00:00 0
7fa84b027000-7fa84b048000 r-xp 00000000 00:20 4847 /lib64/libselinux.so.1Aborted


And last 5 lines from the strace log files ::



close(25) = 0
rt_sigprocmask(SIG_UNBLOCK, [ABRT], NULL, 8) = 0
tgkill(3290, 3290, SIGABRT) = 0
--- SIGABRT {si_signo=SIGABRT, si_code=SI_TKILL, si_pid=3290, si_uid=1000} ---
+++ killed by SIGABRT +++


After the above 5 lines on the strace log, some summery of the error,systemcall, time, etc. is present.



% time seconds usecs/call calls errors syscall
------ ----------- ----------- --------- --------- ----------------
99.71 14.553673 100 145856 poll
0.12 0.017484 0 303657 238030 recvmsg
0.06 0.008083 11 747 getdents
0.05 0.006586 0 27472 1010 futex
0.03 0.004992 1 5023 2157 stat
0.03 0.004070 1 4862 233 open
0.00 0.000514 0 21202 writev
0.00 0.000506 0 8361 1479 read
0.00 0.000312 0 9869 write
0.00 0.000279 0 3856 munmap
0.00 0.000051 0 6005 close
0.00 0.000038 0 257 pwrite
0.00 0.000020 0 4410 mmap
0.00 0.000009 0 103 lstat
0.00 0.000000 0 4415 fstat
0.00 0.000000 0 107 6 lseek
0.00 0.000000 0 400 mprotect
0.00 0.000000 0 210 brk
0.00 0.000000 0 83 rt_sigaction
0.00 0.000000 0 4 rt_sigprocmask
0.00 0.000000 0 12 2 ioctl
0.00 0.000000 0 1186 79 access
0.00 0.000000 0 1 madvise
0.00 0.000000 0 4 shmget
0.00 0.000000 0 4 shmat
0.00 0.000000 0 4 shmctl
0.00 0.000000 0 3 dup
0.00 0.000000 0 12 socket
0.00 0.000000 0 8 connect
0.00 0.000000 0 10 2 sendto
0.00 0.000000 0 17 3 recvfrom
0.00 0.000000 0 10 sendmsg
0.00 0.000000 0 3 shutdown
0.00 0.000000 0 4 bind
0.00 0.000000 0 9 getsockname
0.00 0.000000 0 4 getpeername
0.00 0.000000 0 11 socketpair
0.00 0.000000 0 10 setsockopt
0.00 0.000000 0 183 clone
0.00 0.000000 0 1 execve
0.00 0.000000 0 9 kill
0.00 0.000000 0 35 uname
0.00 0.000000 0 2 shmdt
0.00 0.000000 0 309 2 fcntl
0.00 0.000000 0 2 ftruncate
0.00 0.000000 0 12 getcwd
0.00 0.000000 0 1 unlink
0.00 0.000000 0 43 12 readlink
0.00 0.000000 0 1 getrlimit
0.00 0.000000 0 2 getuid
0.00 0.000000 0 1 getgid
0.00 0.000000 0 4 geteuid
0.00 0.000000 0 3 getegid
0.00 0.000000 0 2 getresuid
0.00 0.000000 0 2 getresgid
0.00 0.000000 0 1 sigaltstack
0.00 0.000000 0 5 1 statfs
0.00 0.000000 0 38 fstatfs
0.00 0.000000 0 1 arch_prctl
0.00 0.000000 0 1 set_tid_address
0.00 0.000000 0 13 fadvise64
0.00 0.000000 0 1 clock_getres
0.00 0.000000 0 1 tgkill
0.00 0.000000 0 2 utimes
0.00 0.000000 0 925 inotify_add_watch
0.00 0.000000 0 383 11 openat
0.00 0.000000 0 1 set_robust_list
0.00 0.000000 0 60 eventfd2
0.00 0.000000 0 2 pipe2
0.00 0.000000 0 1 inotify_init1
------ ----------- ----------- --------- --------- ----------------
100.00 14.596617 550258 243027 total


Can you tell me, if possible, is this due to how i configured my system or something else.

Thanks

malcolmlewis
26-Nov-2014, 07:34
On Wed 26 Nov 2014 06:04:01 AM CST, naren bishayee wrote:


Hello Malcolm,

I've two log files, first one genareted by the 'strace -o' and the
second one actually was on the terminal 'strace -C', and I copied it to
a file

Now, when the Rhythmbox terminated, on the terminal I've seen huge lines
and I can only grab approx 500 lines. Bellow are last three lines from
the strace terminal output ::

Code:
--------------------

7fa84b024000-7fa84b025000 rw-p 00014000 00:20
4933 /lib64/libresolv-2.19.so
7fa84b025000-7fa84b027000 rw-p 00000000 00:00 0
7fa84b027000-7fa84b048000 r-xp 00000000 00:20
4847 /lib64/libselinux.so.1Aborted
--------------------


And last 5 lines from the strace log files ::


Code:
--------------------

close(25) = 0
rt_sigprocmask(SIG_UNBLOCK, [ABRT], NULL, 8) = 0
tgkill(3290, 3290, SIGABRT) = 0
--- SIGABRT {si_signo=SIGABRT, si_code=SI_TKILL, si_pid=3290,
si_uid=1000} --- +++ killed by SIGABRT +++

--------------------


After the above 5 lines on the strace log, some summery of the
error,systemcall, time, etc. is present.


Code:
--------------------

% time seconds usecs/call calls errors syscall
------ ----------- ----------- --------- --------- ----------------
99.71 14.553673 100 145856 poll
0.12 0.017484 0 303657 238030 recvmsg
0.06 0.008083 11 747 getdents
0.05 0.006586 0 27472 1010 futex
0.03 0.004992 1 5023 2157 stat
0.03 0.004070 1 4862 233 open
0.00 0.000514 0 21202 writev
0.00 0.000506 0 8361 1479 read
0.00 0.000312 0 9869 write
0.00 0.000279 0 3856 munmap
0.00 0.000051 0 6005 close
0.00 0.000038 0 257 pwrite
0.00 0.000020 0 4410 mmap
0.00 0.000009 0 103 lstat
0.00 0.000000 0 4415 fstat
0.00 0.000000 0 107 6 lseek
0.00 0.000000 0 400 mprotect
0.00 0.000000 0 210 brk
0.00 0.000000 0 83 rt_sigaction
0.00 0.000000 0 4 rt_sigprocmask
0.00 0.000000 0 12 2 ioctl
0.00 0.000000 0 1186 79 access
0.00 0.000000 0 1 madvise
0.00 0.000000 0 4 shmget
0.00 0.000000 0 4 shmat
0.00 0.000000 0 4 shmctl
0.00 0.000000 0 3 dup
0.00 0.000000 0 12 socket
0.00 0.000000 0 8 connect
0.00 0.000000 0 10 2 sendto
0.00 0.000000 0 17 3 recvfrom
0.00 0.000000 0 10 sendmsg
0.00 0.000000 0 3 shutdown
0.00 0.000000 0 4 bind
0.00 0.000000 0 9 getsockname
0.00 0.000000 0 4 getpeername
0.00 0.000000 0 11 socketpair
0.00 0.000000 0 10 setsockopt
0.00 0.000000 0 183 clone
0.00 0.000000 0 1 execve
0.00 0.000000 0 9 kill
0.00 0.000000 0 35 uname
0.00 0.000000 0 2 shmdt
0.00 0.000000 0 309 2 fcntl
0.00 0.000000 0 2 ftruncate
0.00 0.000000 0 12 getcwd
0.00 0.000000 0 1 unlink
0.00 0.000000 0 43 12 readlink
0.00 0.000000 0 1 getrlimit
0.00 0.000000 0 2 getuid
0.00 0.000000 0 1 getgid
0.00 0.000000 0 4 geteuid
0.00 0.000000 0 3 getegid
0.00 0.000000 0 2 getresuid
0.00 0.000000 0 2 getresgid
0.00 0.000000 0 1 sigaltstack
0.00 0.000000 0 5 1 statfs
0.00 0.000000 0 38 fstatfs
0.00 0.000000 0 1 arch_prctl
0.00 0.000000 0 1 set_tid_address
0.00 0.000000 0 13 fadvise64
0.00 0.000000 0 1 clock_getres
0.00 0.000000 0 1 tgkill
0.00 0.000000 0 2 utimes
0.00 0.000000 0 925 inotify_add_watch
0.00 0.000000 0 383 11 openat
0.00 0.000000 0 1 set_robust_list
0.00 0.000000 0 60 eventfd2
0.00 0.000000 0 2 pipe2
0.00 0.000000 0 1 inotify_init1
------ ----------- ----------- --------- --------- ----------------
100.00 14.596617 550258 243027 total

--------------------


Can you tell me, if possible, is this due to how i configured my system
or something else.

Thanks




Hi
So something is calling for the program to abort..... hard to say :(

So if you use gdb;


gdb /usr/bin/rhythmbox
run

See if we can see why it fails.... I have it here running ok.

The other option, create a test user and login as the test user, does
it duplicate? That indicates system wide, else it will just be as your
user.

--
Cheers Malcolm °¿° LFCS, SUSE Knowledge Partner (Linux Counter #276890)
SUSE Linux Enterprise Desktop 12 GNOME 3.10.1 Kernel 3.12.28-4-default
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below... Thanks!

naren_bishayee
26-Nov-2014, 08:02
Hi Malcolm,

I'll do it again with gdb.

But One thing, On the strace terminal output, why it says '/lib64/libselinux.so.1Aborted'
I think it's SELinux module/library.
My knowldge says SLED ships apparmor and SELinux on the SLED 12, but by default apparmor is active

Thanks

naren_bishayee
11-Dec-2014, 06:02
Hi All,
This time Evolution hang two times. Bellow are the details ::


Compose mail, click the attachment. After go to the directory where I've the documents, using 'Files' browser, add more documents on there and when back to the evolution mail attachment window a popup window appear & says 'my subjectline' is not responding with 'Wait' and 'Force Quit' button

The gdb output says ::


Gtk:ERROR:gtkrbtree.c:465:_gtk_rbtree_insert_after : assertion failed: (_gtk_rbtree_is_nil (tree->root))

Program received signal SIGABRT, Aborted.
0x00007ffff391e187 in raise () from /lib64/libc.so.6


Trying write a new mail, popup window appear with 'Wait' and 'Force Quit' button

After click the 'Wait' in a minute the compose screen display & active

The gdb output says ::

(evolution:4831): evolution-util-CRITICAL **: e_contact_store_get_contact: assertion 'ITER_IS_VALID (contact_store, iter)' failed

(evolution:4831): libebook-contacts-CRITICAL **: e_contact_get: assertion 'contact && E_IS_CONTACT (contact)' failed

(evolution:4831): libebook-contacts-CRITICAL **: e_contact_get: assertion 'contact && E_IS_CONTACT (contact)' failed

(evolution:4831): libebook-contacts-CRITICAL **: e_contact_get: assertion 'contact && E_IS_CONTACT (contact)' failed

(evolution:4831): evolution-util-CRITICAL **: e_contact_store_get_contact: assertion 'ITER_IS_VALID (contact_store, iter)' failed

naren_bishayee
11-Dec-2014, 13:07
Also on the gdb I've found the bellow error ::


(process:13677): GLib-CRITICAL **: g_slice_set_config: assertion 'sys_page_size == 0' failed


Hi All,
This time Evolution hang two times. Bellow are the details ::



The gdb output says ::


Gtk:ERROR:gtkrbtree.c:465:_gtk_rbtree_insert_after : assertion failed: (_gtk_rbtree_is_nil (tree->root))

Program received signal SIGABRT, Aborted.
0x00007ffff391e187 in raise () from /lib64/libc.so.6



The gdb output says ::

(evolution:4831): evolution-util-CRITICAL **: e_contact_store_get_contact: assertion 'ITER_IS_VALID (contact_store, iter)' failed

(evolution:4831): libebook-contacts-CRITICAL **: e_contact_get: assertion 'contact && E_IS_CONTACT (contact)' failed

(evolution:4831): libebook-contacts-CRITICAL **: e_contact_get: assertion 'contact && E_IS_CONTACT (contact)' failed

(evolution:4831): libebook-contacts-CRITICAL **: e_contact_get: assertion 'contact && E_IS_CONTACT (contact)' failed

(evolution:4831): evolution-util-CRITICAL **: e_contact_store_get_contact: assertion 'ITER_IS_VALID (contact_store, iter)' failed

malcolmlewis
11-Dec-2014, 13:45
On Thu 11 Dec 2014 05:04:01 AM CST, naren bishayee wrote:


Hi All,
This time Evolution hang two times. Bellow are the details ::

> Compose mail, click the attachment. After go to the directory where
> I've the documents, using 'Files' browser, add more documents on
> there and when back to the evolution mail attachment window a popup
> window appear & says 'my subjectline' is not responding with 'Wait'
> and 'Force Quit' button

The gdb output says ::


Code:
--------------------
Gtk:ERROR:gtkrbtree.c:465:_gtk_rbtree_insert_after : assertion
failed: (_gtk_rbtree_is_nil (tree->root))
Program received signal SIGABRT, Aborted.
0x00007ffff391e187 in raise () from /lib64/libc.so.6
--------------------


> Trying write a new mail, popup window appear with 'Wait' and 'Force
> Quit' button
>
> After click the 'Wait' in a minute the compose screen display & active

The gdb output says ::

Code:
--------------------
(evolution:4831): evolution-util-CRITICAL **:
e_contact_store_get_contact: assertion 'ITER_IS_VALID (contact_store,
iter)' failed (evolution:4831): libebook-contacts-CRITICAL **:
e_contact_get: assertion 'contact && E_IS_CONTACT (contact)' failed
(evolution:4831): libebook-contacts-CRITICAL **: e_contact_get:
assertion 'contact && E_IS_CONTACT (contact)' failed
(evolution:4831): libebook-contacts-CRITICAL **: e_contact_get:
assertion 'contact && E_IS_CONTACT (contact)' failed
(evolution:4831): evolution-util-CRITICAL **:
e_contact_store_get_contact: assertion 'ITER_IS_VALID (contact_store,
iter)' failed --------------------


Hi
This one seems to be the same...
https://bugzilla.gnome.org/show_bug.cgi?id=733868
Debug packages required to be installed...
https://wiki.gnome.org/Community/GettingInTouch/Bugzilla/GettingTraces

I think once you have more info, you might consider raising a bug
at; https://bugzilla.suse.com/index.cgi

--
Cheers Malcolm °¿° LFCS, SUSE Knowledge Partner (Linux Counter #276890)
SUSE Linux Enterprise Desktop 12 GNOME 3.10.1 Kernel 3.12.28-4-default
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below... Thanks!