PDA

View Full Version : Working with SDB...



ddgaikwad
15-Apr-2015, 11:46
Hi There!

I am trying to setup cluster for Sentinel servers using this document here: https://www.netiq.com/documentation/sentinel72/s721_install/data/b13k8oh7.html

I am using a single iSCSI exposed target, where in I have created two partitions, one of 40 GB and another of 10 MB, which would be SDB.
The cluster configuration goes just fine, but, when I try to add the other node to the cluster using sleha-join, I get the error, failed to probe new partitions.

The question that I have is that, is the process that I am following right?
Or is there any specific method which I need to follow in order to have a SDB on the same exposed drive as a separate partition...

Please assist.
Thank you!

ab
15-Apr-2015, 12:36
I would probably stick with giving SBD its own device, and not just a
partition on a device. I've never seen an example providing a way to just
use partitions, but considering SBD's purpose having it on a shared device
seems like the wrong approach.

--
Good luck.

If you find this post helpful and are logged into the web interface,
show your appreciation and click on the star below...

ddgaikwad
15-Apr-2015, 13:35
So, that is why I am getting this, error, "Probing for new partitions......WARNING: Failed to probe new partitions" when I running sleha-join on the second node.
Here is the complete output:
SenHA02:~ # sleha-join
WARNING: NTP is not configured to start at system boot.
Do you want to continue anyway? [y/N] y

Join This Node to Cluster:
You will be asked for the IP address of an existing node, from which
configuration will be copied. If you have not already configured
passwordless ssh between nodes, you will be prompted for the root
password of the existing node.

IP address or hostname of existing node (e.g.: 192.168.1.1) [] 2.2.2.202
Enabling sshd service
Retrieving SSH keys from 2.2.2.202
Password:
Configuring csync2
Enabling csync2 service
Enabling xinetd service
Merging known_hosts
Probing for new partitions......WARNING: Failed to probe new partitions
done
Enabling hawk service
HA Web Konsole is now running, to see cluster status go to:
https://2.2.2.203:7630/
Log in with username 'hacluster', password 'linux'
WARNING: You should change the hacluster password to something more secure!
Enabling openais service
ERROR: Failed to start openais service

So, that means, its not supported to have sdb on the same disk as a separate partition...?
Right..?

jmozdzen
17-Apr-2015, 11:42
Hi ddgaikwad,

So, that is why I am getting this, error, "Probing for new partitions......WARNING: Failed to probe new partitions" when I running sleha-join on the second node.
[...]
So, that means, its not supported to have sdb on the same disk as a separate partition...?
Right..?

in our current setup, we have SDB running on a partition of a shared device:


xen101:/usr/lib64/stonith/plugins/external # cat /etc/sysconfig/sbd
SBD_DEVICE="/dev/disk/by-id/scsi-1SCST_FIOe714a0bc-xenserver-lun0-part1"
SBD_OPTS="-W"
xen101:/usr/lib64/stonith/plugins/external # fdisk -l /dev/disk/by-id/scsi-1SCST_FIOe714a0bc-xenserver-lun0

Disk /dev/disk/by-id/scsi-1SCST_FIOe714a0bc-xenserver-lun0: 742 MB, 742694912 bytes
23 heads, 62 sectors/track, 1017 cylinders, total 1450576 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 524288 bytes
Disk identifier: 0xc792c14e

Device Boot Start End Blocks Id System
/dev/disk/by-id/scsi-1SCST_FIOe714a0bc-xenserver-lun0-part1 2048 10239 4096 83 Linux
/dev/disk/by-id/scsi-1SCST_FIOe714a0bc-xenserver-lun0-part2 10240 215039 102400 83 Linux
xen101:/usr/lib64/stonith/plugins/external #

and we were using "sleha-join" to join the second node.

Have you made sure the device/partition you have configured on your first node, is available under the exact same name on the second node?

Regards,
Jens