PDA

View Full Version : bug in identd on SLES11sp1



heinkonijn
15-Feb-2012, 20:56
I had to install the identd rpm on my SLES11sp1 server for PostgreSQL authentication.

I think I have found a bug in the package.

The issue is that the identd service will not start after it has been installed.
If you check the log it claims it cannot create a listener on TCP port 138.

After some troubleshooting I found out that it does work if you force the daemon to start a listener on localhost.

The "fix" is:
===========================
vi /etc/init.d/identd
Update the start section and replace:
startproc -q $IDENTD_BIN e
with
startproc -q $IDENTD_BIN e a 127.0.0.1
===========================

It might have something to do with the fact I disabled IPv6, but haven't checked that. (shouldn't really matter I would say)

Can someone notify the package maintainer about this, or point me to the right person?

Thanks,
Hein

malcolmlewis
18-Feb-2012, 16:29
I had to install the identd rpm on my SLES11sp1 server for PostgreSQL
authentication.

I think I have found a bug in the package.

The issue is that the identd service will not start after it has been
installed.
If you check the log it claims it cannot create a listener on TCP port
138.

After some troubleshooting I found out that it does work if you force
the daemon to start a listener on localhost.

The "fix" is:
===========================
vi /etc/init.d/identd
Update the “start” section and replace:
startproc -q $IDENTD_BIN –e
with
startproc -q $IDENTD_BIN –e –a 127.0.0.1
===========================

It might have something to do with the fact I disabled IPv6, but
haven't checked that. (shouldn't really matter I would say)

Can someone notify the package maintainer about this, or point me to
the right person?

Thanks,
Hein



Hi
I would raise a bug in bugzilla which will get the package maintainers
attention ;)
https://bugzilla.novell.com/index.cgi


--
Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 3.0.13-0.19-default
up 2 days 11:29, 3 users, load average: 0.00, 0.02, 0.05
CPU Intel i5 CPU M520@2.40GHz | Intel Arrandale GPU