PDA

View Full Version : How to install google chrome onto SLES 11 SP3



hatelove85911
18-Jun-2015, 03:06
I'm used to google chrome, so I want it on my company pc which has SLES 11 SP3 installed. When I try to install it, I get following issues:


Problem: google-chrome-stable-43.0.2357.125-1.x86_64 requires libX11.so.6()(64bit), but this requirement cannot be provided
uninstallable providers: xorg-x11-libX11-7.4-5.9.1.x86_64[SLES11-SP3-Pool]
Solution 1: do not install google-chrome-stable-43.0.2357.125-1.x86_64
Solution 2: break google-chrome-stable-43.0.2357.125-1.x86_64 by ignoring some of its dependencies

The problem is:
I can see package: xorg-x11-libX11 is installed in yast2, version is 7.4-5.11.11.1.

And I can see libX11.so.6 is sitting in /usr/lib64/,


libX11.so
libX11.so.6
libX11.so.6.2.0
Why is chrome still telling me libX11.so.6()(64bit) can't be provided?

And what does uninstallable providers: xorg-x11-libX11-7.4-5.9.1.x86_64[SLES11-SP3-Pool] mean? From what I see the version already installed: 7.4-5.11.11.1 is already higher than the version it requires.

Automatic reply
22-Jun-2015, 05:30
hatelove85911,

It appears that in the past few days you have not received a response to your
posting. That concerns us, and has triggered this automated reply.

Has your issue been resolved? If not, you might try one of the following options:

- Visit http://www.suse.com/support and search the knowledgebase and/or check all
the other support options available.
- You could also try posting your message again. Make sure it is posted in the
correct newsgroup. (http://forums.suse.com)

Be sure to read the forum FAQ about what to expect in the way of responses:
http://forums.suse.com/faq.php

If this is a reply to a duplicate posting, please ignore and accept our apologies
and rest assured we will issue a stern reprimand to our posting bot.

Good luck!

Your SUSE Forums Team
http://forums.suse.com

smflood
22-Jun-2015, 10:21
On 18/06/2015 03:14, hatelove85911 wrote:

> I'm used to google chrome, so I want it on my company pc which has SLES
> 11 SP3 installed.

SLES is SUSE Linux Enterprise Server - for a workstation I'd expect you
to be running SUSE Linux Enterprise Desktop (SLED). Please can you
confirm that you're running SLES by posting the output from "cat
/etc/*release".

> When I try to install it, I get following issues:
>
>
> Problem: google-chrome-stable-43.0.2357.125-1.x86_64 requires
> libX11.so.6()(64bit), but this requirement cannot be provided
> uninstallable providers:
> xorg-x11-libX11-7.4-5.9.1.x86_64[SLES11-SP3-Pool]
> Solution 1: do not install google-chrome-stable-43.0.2357.125-1.x86_64
> Solution 2: break google-chrome-stable-43.0.2357.125-1.x86_64 by
> ignoring some of its dependencies
>
> The problem is:
> I can see package: xorg-x11-libX11 is installed in yast2, version is
> 7.4-5.11.11.1.
>
> And I can see libX11.so.6 is sitting in /usr/lib64/,
>
>
> libX11.so
> libX11.so.6
> libX11.so.6.2.0
> Why is chrome still telling me libX11.so.6()(64bit) can't be provided?
>
> And what does uninstallable providers:
> xorg-x11-libX11-7.4-5.9.1.x86_64[SLES11-SP3-Pool] mean? From what I see
> the version already installed: 7.4-5.11.11.1 is already higher than the
> version it requires.

Where did you download the Google Chrome package from? It's not one
provided with or by SUSE and therefore not supported. Replacing X
windows-related packages in SLEx is not a good idea.

HTH.
--
Simon
SUSE Knowledge Partner

------------------------------------------------------------------------
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below. Thanks.
------------------------------------------------------------------------