PDA

View Full Version : SLES 12 SLES 12 SP 1 - openssl version (upgrade)



rw_ww
03-Feb-2016, 11:23
Hi folks!

I finished installing SLES 12 and now I'm wondering why openssl still got version 1.0.1li-fips 6 Aug 2014. How do I upgrade to a recent version (i.e. 1.0.1r) or directly switch to 1.0.2f?

Cheers
Ralf:confused:

smflood
03-Feb-2016, 12:15
On 03/02/2016 10:24, rw ww wrote:

> I finished installing SLES 12 and now I'm wondering why openssl still
> got version 1.0.1li-fips 6 Aug 2014. How do I upgrade to a recent
> version (i.e. 1.0.1r) or directly switch to 1.0.2f?

Just because the latest version of openSSL may be x.y.z doesn't mean
that SUSE will package and release version x.y.z for particular versions
of SLES. Instead what SUSE do for stability and support (SLES is an
Enterprise product) is backport security fixes from later versions into
packages of earlier versions.

Is there a particular fix or feature that you're looking for from 1.0.1r
or 1.0.2f?

HTH.
--
Simon
SUSE Knowledge Partner

------------------------------------------------------------------------
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below. Thanks.
------------------------------------------------------------------------

rw_ww
11-Feb-2016, 11:06
Simon,

thank you for your answer! Maybe not the latest version should be provided, but the installed version ist 15 month old and I'm wondering, how

https://www.openssl.org/news/openssl-1.0.1-notes.html will be handled? In general I would like to use GW2014 Webaccess with TLS support > 1.0.

Cheers
Ralf

smflood
11-Feb-2016, 11:57
On 11/02/2016 10:14, rw ww wrote:

> thank you for your answer! Maybe not the latest version should be
> provided, but the installed version ist 15 month old and I'm wondering,
> how
>
> https://www.openssl.org/news/openssl-1.0.1-notes.html will be handled?
> In general I would like to use GW2014 Webaccess with TLS support > 1.0.

If you're asking about GroupWise then probably best if you post to the
GroupWise 2014 Web Access forum @
https://forums.novell.com/forumdisplay.php/1303-GW2014-Web-Access

I did find TID 7016958[1] but I'm sure that actually answers the question.

HTH.

[1] https://www.novell.com/support/kb/doc.php?id=7016958
--
Simon
SUSE Knowledge Partner

------------------------------------------------------------------------
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below. Thanks.
------------------------------------------------------------------------

thsundel
11-Feb-2016, 12:13
On 11/02/2016 10:14, rw ww wrote:

> thank you for your answer! Maybe not the latest version should be
> provided, but the installed version ist 15 month old and I'm wondering,
> how
>
> https://www.openssl.org/news/openssl-1.0.1-notes.html will be handled?
> In general I would like to use GW2014 Webaccess with TLS support > 1.0.

If you're asking about GroupWise then probably best if you post to the
GroupWise 2014 Web Access forum @
https://forums.novell.com/forumdisplay.php/1303-GW2014-Web-Access

I did find TID 7016958[1] but I'm sure that actually answers the question.

HTH.

[1] https://www.novell.com/support/kb/doc.php?id=7016958
--
Simon
SUSE Knowledge Partner

------------------------------------------------------------------------
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below. Thanks.
------------------------------------------------------------------------

I believe TID7016958 is only for communications between the groupwise system agents not between browser and webacc.

Thomas