PDA

View Full Version : Patch SUSE-SLE-SERVER-12-SP1-2016-329 may have problems on aSLES11SP4 Dom0



Franz Sirl
01-Mar-2016, 09:29
Hi,

after installing SUSE-SLE-SERVER-12-SP1-2016-329 in a DomU the new
kernel (3.12.53-60.30.1) crashed shortly after reboot here. Updating the
Dom0 SLES11SP4 to the latest patches didn't make a difference. After
re-activating to previous kernel (3.12.51-60.25.1) everything was fine
again.

It will take some time until I have resources to investigate further, so
just a heads-up for now.

Franz

jmozdzen
01-Mar-2016, 14:50
Hi Franz,

thank you for the heads-up - I've forwarded your report to my SUSE contact, and will relay any important responses.

Regards,
Jens

jmozdzen
02-Mar-2016, 17:59
Hi Franz,

if you feel you need the new kernel, you can try to change the DomU grub2 config to load "vmlinux-3.12.53-60.30-xen.gz" instead of "vmlinuz-xen". This seems to work around the problem.

Regards,
Jens

Franz Sirl
21-Mar-2016, 11:01
Hi Jens,

I symlinked vmlinux-3.12.53-60.30-xen.gz to vmlinuz-xen, that worked
well. Just now I updated the Xen-host to SLES12SP1 and here the original
configuration of the guest works fine. But probably only since SLES12SP1
received the SUSE-SLE-SERVER-12-SP1-2016-375 patch. Seems this patch
hasn't reached SLES11SP4 yet.

Thanks for your help,
Franz


Am 2016-03-02 um 18:04 schrieb jmozdzen:
>
> Hi Franz,
>
> if you feel you need the new kernel, you can try to change the DomU
> grub2 config to load "vmlinux-3.12.53-60.30-xen.gz" instead of
> "vmlinuz-xen". This seems to work around the problem.
>
> Regards,
> Jens
>
>