PDA

View Full Version : Creation of Tools Repo for SLES11 SP2 fails on SuMa 3



oackerma
22-Jun-2016, 11:19
Hi,

Creation of SuMa 3 Tools Repository for SLE11 SP2 fails with the following error:


srvms1suma:~ # mgr-create-bootstrap-repo -c SLE-11-SP2-x86_64
copy 'dbus-1-python-0.83.0-27.1.43.x86_64'
...
copy 'zypper-1.6.178-0.5.3.x86_64'
ERROR: package 'libyaml-0-2' not found

The objected libyaml-0-2 simply seems to be missing.
All SUSE channels have been synced completely, esp. SLES11 SP1/2 x86_64.
No problems with creating other tools repositorys, e.g., SLES11 SP3/4 and SLES12 SP1.

Any hint appreciated.

kwk
23-Jun-2016, 13:19
Two answers

- SLES 11 SP2 is out of maintenance, please upgrade to a supported service pack
- the mgr-create-bootstrap-repo problem is fixed with the latest updates. Please patch your SUSE Manager server.

oackerma
23-Jun-2016, 14:32
Right,
after patching and running a schema upgrade on the SuMa server the issue is resolved.
Thank you for your help.

willduckworth
11-Jul-2016, 10:47
Hi
I am also having the same, or very similar problem, SuMa3, creating repo for a lot of versions and CPUs give the no 'hwdata' or
ERROR: package 'libyaml-0-2' not found

my schema seems to be up to date:

spacewalk-schema-upgrade
Schema upgrade: [susemanager-schema-3.0.13-3.2] -> [susemanager-schema-3.0.13-3.2]
Searching for upgrade path to: [susemanager-schema-3.0.13-3.2]
Searching for upgrade path to: [susemanager-schema-3.0.13]
Your database schema already matches the schema package version [susemanager-schema-3.0.13-3.2].

anyone got any ideas about this - maybe clearing out/re-updating/forcing upgrade or something?
thanks
Will

willduckworth
18-Aug-2016, 10:10
Hi
Just to let everyone know - all sorted. This was an evaluation version and I needed to apply the eval key as well as the organization key. Then patched SuMa and things worked fine, so looked like me not following instructions fully - oops