PDA

View Full Version : No glibc-devel-static ?



mabman
22-Jan-2017, 06:51
Hello, I've finally gotten SLES working as I like it on my Raspberry Pi 3.

One thing is missing - I would like to be able to statically compile applications using gcc. I am unable to do this because the static version of glibc is not available. (I can squeeze a little more performance out of a CPU-bound application this way - it works correctly in Raspbian on the same hardware.)

After some searching, it appears I need the package "glibc-devel-static", which is not available from the SUSE repositories. Further searching seems to indicate it is available in general, but only as part of the SLES 12 Development Kit. However, there is no Development Kit for AARCH64.

Some searching at rpmfind.net suggests there *are* AARCH64 RPMs available, but the versions need to match the installed version of glibc-devel, and if they don't, glibc-devel-static won't install (I tested this). The highest version I see on rpmfind.net is 2.19-22.1, which requires the same version of plain glibc-devel. The glibc-devel version installed on SLES is 2.22-49.16.

I really don't want to mess around with downgrading glibc-devel to get glibc-devel-static to install, as glibc is a dependency for many (all?) system tools and that could be bad.

I suspect I'm out of luck at this point - by chance does anyone have a glibc-devel-static AARCH64 RPM for version 2.22-49.16 ?

Thanks!

malcolmlewis
22-Jan-2017, 15:14
On Sun 22 Jan 2017 05:54:01 AM CST, mabman wrote:

Hello, I've finally gotten SLES working as I like it on my Raspberry Pi
3.

One thing is missing - I would like to be able to statically compile
applications using gcc. I am unable to do this because the static
version of glibc is not available. (I can squeeze a little more
performance out of a CPU-bound application this way - it works correctly
in Raspbian on the same hardware.)

After some searching, it appears I need the package
"glibc-devel-static", which is not available from the SUSE repositories.
Further searching seems to indicate it is available in general, but
only as part of the SLES 12 Development Kit. However, there is no
Development Kit for AARCH64.

Some searching at rpmfind.net suggests there *are* AARCH64 RPMs
available, but the versions need to match the installed version of
glibc-devel, and if they don't, glibc-devel-static won't install (I
tested this). The highest version I see on rpmfind.net is 2.19-22.1,
which requires the same version of plain glibc-devel. The glibc-devel
version installed on SLES is 2.22-49.16.

I really don't want to mess around with downgrading glibc-devel to get
glibc-devel-static to install, as glibc is a dependency for many (all?)
system tools and that could be bad.

I suspect I'm out of luck at this point - by chance does anyone have a
glibc-devel-static AARCH64 RPM for version 2.22-49.16 ?

Thanks!




Hi
AFAIK, the SDK is coming... (See
http://forums.suse.com/showthread.php?t=8794) may bump the thread I
linked...

--
Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
openSUSE Leap 42.1|GNOME 3.16.2|4.1.36-44-default
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below... Thanks!

mabman
22-Jan-2017, 17:42
Hi
AFAIK, the SDK is coming... (See
http://forums.suse.com/showthread.php?t=8794) may bump the thread I
linked...

--
Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
openSUSE Leap 42.1|GNOME 3.16.2|4.1.36-44-default
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below... Thanks!

Good news, thanks!