PDA

View Full Version : User Abort code??



kaywokke
28-Mar-2012, 15:11
Download (curl) error for "https://nu.novell.com/repo/$RCE/SLED11-SP1-pool/sle-11-i568/repodata/repomd.xml?
credentials=NCCcredentials"
Error code: User abort
Error message: connect() timed out!

How is this possible?

malcolmlewis
28-Mar-2012, 15:20
Download (curl) error for
"https://nu.novell.com/repo/$RCE/SLED11-SP1-pool/sle-11-i568/repodata/repomd.xml?
credentials=NCCcredentials"
Error code: User abort
Error message: connect() timed out!

How is this possible?



Hi
There are a few things to setup if your going through a proxy;

Your proxy should should accept Novell domain (or at least selected
sites used like nu.novell.com and secure.novell.com) without
authentication.

You need to populate proxy setting in YAST and to add two lines
with your proxy information to /etc/profile, for example:

export http_proxy="http://10.10.1.1:8081/"
export https_proxy="https://10.10.1.1:8081/"

As well as the /root/.curlrc

Then I would login to the NCC web page and delete the system and
re-register it.



suse_register -a regcode-sles=YourActivationCode -a email=YourEmailAddress -a moniker=YourHostname -L .suse_register.log


--
Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 3.0.13-0.27-default
up 2 days 20:25, 2 users, load average: 0.02, 0.04, 0.05
CPU Intel i5 CPU M520@2.40GHz | Intel Arrandale GPU

kaywokke
02-Apr-2012, 07:22
In /etc/profile where must i set
export http_proxy="http://10.10.1.1:8081/"
export https_proxy="https://10.10.1.1:8081/"
??

And NCC web page what web page is that i am a noob with Suse Desktop...

kaywokke
02-Apr-2012, 07:26
I get the same error :S i dont know how it is possible ??

malcolmlewis
02-Apr-2012, 14:33
In /etc/profile where must i set
export http_proxy="http://10.10.1.1:8081/"
export https_proxy="https://10.10.1.1:8081/"
??

And NCC web page what web page is that i am a noob with Suse Desktop...



Hi
You just append those two lines at the end of the file, replace the ip
address with your proxy ip address.

--
Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 3.0.13-0.27-default
up 12:19, 2 users, load average: 0.00, 0.02, 0.05
CPU Intel i5 CPU M520@2.40GHz | Intel Arrandale GPU

kaywokke
03-Apr-2012, 07:29
I have add that 2 lines but gave this error again :S
An error occurred during repository initialization.
Download (curl) error for 'https://nu.novell.com/repo/repoindex.xml?cookies=0&credentials=NCCcredentials':
Error code: User abort
Error message: connect() timed out!

who can help me !!!!

kaywokke
04-Apr-2012, 10:58
He still gave me user abort errors i have throw away the system in NCC and i have add it but it still doesn't work.

malcolmlewis
05-Apr-2012, 16:11
He still gave me user abort errors i have throw away the system in NCC
and i have add it but it still doesn't work.



Hi
So have you re-registed via the command line in my previous post
and looked through the log file to see what may be happening?


--
Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 3.0.13-0.27-default
up 21:16, 3 users, load average: 0.00, 0.02, 0.05
CPU Intel i5 CPU M520@2.40GHz | Intel Arrandale GPU

kaywokke
10-Apr-2012, 08:29
It gave me a error:

suse_register -a regcode-sles=Myregcode -a email=My-Emailadress
ERROR: Timeout was reached: (28)
(2)
ERROR: Timeout was reached: (28)
(2)

kaywokke
16-Apr-2012, 13:25
Do you have a answer for this?

malcolmlewis
16-Apr-2012, 14:09
Do you have a answer for this?

Hi
So you have setup all the files as indicated previously?

The only thing I can think of is the network issues that have been
present on the Attachmate side of things when you have been trying.

You have tried lately and still get the same log error?

--
Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 3.0.13-0.27-default
up 1 day 10:59, 2 users, load average: 0.00, 0.01, 0.05
CPU Intel i5 CPU M520@2.40GHz | Intel Arrandale GPU

kaywokke
16-Apr-2012, 14:25
Yes get the same error everytime it is a SERVER NOT REACHED (28)

kaywokke
17-Apr-2012, 12:28
Someone got a solution for this problem?

malcolmlewis
17-Apr-2012, 14:28
Someone got a solution for this problem?



Hi
Can you confirm the proxy is present, if in firefox add your proxy and
then browse to http://www.google.com is this successful?



--
Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 3.0.13-0.27-default
up 14:06, 2 users, load average: 0.00, 0.01, 0.05
CPU Intel i5 CPU M520@2.40GHz | Intel Arrandale GPU

kaywokke
19-Apr-2012, 07:31
Yes that works perfectly :-)

lpphiggp
16-Sep-2013, 16:30
For what's its worth, I have a SLES11sp2 box with nearly the same problem.
I've checked the .curlrc file, (BTW the proper syntax there is "--proxy http://proxyname:port/")
All those settings are good.

Proxy is set in Yast.
If I test with Firefox, I set FF to use system proxy (instead of explicitly defining it) and it works fine; our proxy has a special list of servers and sites that bypass authentication; all novell, suse, and attachmategroup sites are in the list. This also tests successfully in Firefox.

But when I try to refresh my repositories, it tells me it can't resolve nu.novell.com.
If it were using the proxy properly, it would.
I can type nu.novell.com into Firefox, and while I get an expected 403 error, at least it proves it's resolving through the proxy - it gets there.

Seems something in curl is broken.
(BTW we have other servers that are in fact working.. so the proxy is okay, it's something on this SLES box)

malcolmlewis
17-Sep-2013, 00:40
For what's its worth, I have a SLES11sp2 box with nearly the same problem.
I've checked the .curlrc file, (BTW the proper syntax there is "--proxy http://proxyname:port/")
All those settings are good.

Proxy is set in Yast.
If I test with Firefox, I set FF to use system proxy (instead of explicitly defining it) and it works fine; our proxy has a special list of servers and sites that bypass authentication; all novell, suse, and attachmategroup sites are in the list. This also tests successfully in Firefox.

But when I try to refresh my repositories, it tells me it can't resolve nu.novell.com.
If it were using the proxy properly, it would.
I can type nu.novell.com into Firefox, and while I get an expected 403 error, at least it proves it's resolving through the proxy - it gets there.

Seems something in curl is broken.
(BTW we have other servers that are in fact working.. so the proxy is okay, it's something on this SLES box)
Hi
So if you delete the system on the NCC page and re-register, does that work ok?