PDA

View Full Version : Wireless stop working after SLED 11 SP2 update



Arnaudk93
01-Apr-2012, 16:43
Hi !

My broadcom wireless card seems to don't be properly detected by SP2. It worked under SP1

Here lspci :
02:00.0 Network controller: Broadcom Corporation BCM4312 802.11b/g LP-PHY (rev 01)


ifup wireless detect no wireless network.

No error while booting the system.

Any idea ?

Regards,

Arnaud

svalx
02-Apr-2012, 07:07
01.04.2012 19:44, Arnaudk93 wrote:
>
> My broadcom wireless card seems to don't be properly detected by SP2.
> It worked under SP1
> Any idea ?
>
May be migrate to b43? Or update wl for 3.x kernel?

Arnaudk93
02-Apr-2012, 13:14
Is there a RPM to do so ?

malcolmlewis
02-Apr-2012, 14:36
Hi !

My broadcom wireless card seems to don't be properly detected by SP2.
It worked under SP1

Here lspci :
02:00.0 Network controller: Broadcom Corporation BCM4312 802.11b/g
LP-PHY (rev 01)


ifup wireless detect no wireless network.

No error while booting the system.

Any idea ?

Regards,

Arnaud



Hi
If you pop over the the openSUSE forums in the wireless section there
are some 'stickies' at the beginning of the forum on what to do.

If your still having problems post the info requested in those stickies
and will ask the broadcom wireless kernel developer who hangs out in
the openSUSE forum to pop in here for some assistance.

--
Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 3.0.13-0.27-default
up 12:21, 2 users, load average: 0.00, 0.01, 0.05
CPU Intel i5 CPU M520@2.40GHz | Intel Arrandale GPU

svalx
02-Apr-2012, 18:41
02.04.2012 16:24, Arnaudk93 написал:
>
> Is there a RPM to do so ?
>

Are you have wl driver installed? If it is true, try to update driver
from
http://h20000.www2.hp.com/bizsupport/TechSupport/SoftwareDescription.jsp?lang=ru&cc=ru&prodTypeId=321957&prodSeriesId=5079419&prodNameId=5079420&swEnvOID=2020&swLang=33&mode=2&taskId=135&swItem=ob-95491-1

* Английский - определен
* Английский
* Русский

* Английский
* Русский

<javascript:void(0);>
Не удалось перевести выделенный текст.

malcolmlewis
02-Apr-2012, 18:50
02.04.2012 16:24, Arnaudk93 написал:
>
> Is there a RPM to do so ?
>

Are you have wl driver installed? If it is true, try to update driver
from
http://h20000.www2.hp.com/bizsupport/TechSupport/SoftwareDescription.jsp?lang=ru&cc=ru&prodTypeId=321957&prodSeriesId=5079419&prodNameId=5079420&swEnvOID=2020&swLang=33&mode=2&taskId=135&swItem=ob-95491-1

* Английский - определен
* Английский
* Русский

* Английский
* Русский

<javascript:void(0);>
Не удалось перевести выделенный текст.

Hi
SP2 has the 3.0.13, not the 2.6.32 so it's incompatible.....

It's also for the b/g/n device AFAIK the OP only has a b/g device.

I'm running a Broadcom Corporation BCM43224 802.11a/b/g/n [14e4:4353]
(rev 01) device device, but built my own KMP as it's using brcmsmac.
http://software.opensuse.org/search?q=brcmsmac&baseproject=SUSE%3ASLE-11%3ASP2&lang=en&include_home=true&exclude_debug=true

--
Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 3.0.13-0.27-default
up 16:33, 2 users, load average: 0.00, 0.01, 0.05
CPU Intel i5 CPU M520@2.40GHz | Intel Arrandale GPU

Arnaudk93
04-Apr-2012, 14:33
Hi
SP2 has the 3.0.13, not the 2.6.32 so it's incompatible.....

It's also for the b/g/n device AFAIK the OP only has a b/g device.

I'm running a Broadcom Corporation BCM43224 802.11a/b/g/n [14e4:4353]
(rev 01) device device, but built my own KMP as it's using brcmsmac.
http://software.opensuse.org/search?q=brcmsmac&baseproject=SUSE%3ASLE-11%3ASP2&lang=en&include_home=true&exclude_debug=true

--
Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 3.0.13-0.27-default
up 16:33, 2 users, load average: 0.00, 0.01, 0.05
CPU Intel i5 CPU M520@2.40GHz | Intel Arrandale GPU
Hi Malcom,

Do I need to build the brcmsmac SRPM then install it, and install the PAE module after ?
I will try it later this week.

Regards,

Arnaud

malcolmlewis
04-Apr-2012, 14:46
malcolmlewis;3844 Wrote:
> Hi
> SP2 has the 3.0.13, not the 2.6.32 so it's incompatible.....
>
> It's also for the b/g/n device AFAIK the OP only has a b/g device.
>
> I'm running a Broadcom Corporation BCM43224 802.11a/b/g/n [14e4:4353]
> (rev 01) device device, but built my own KMP as it's using brcmsmac.
> http://software.opensuse.org/search?q=brcmsmac&baseproject=SUSE%3ASLE-11%3ASP2&lang=en&include_home=true&exclude_debug=true
>
> --
> Cheers Malcolm °¿° (Linux Counter #276890)
> SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 3.0.13-0.27-default
> up 16:33, 2 users, load average: 0.00, 0.01, 0.05
> CPU Intel i5 CPU M520@2.40GHz | Intel Arrandale GPU
Hi Malcom,

Do I need to build the brcmsmac SRPM then install it, and install the
PAE module after ?
I will try it later this week.

Regards,

Arnaud



Hi
Just select the 1-click for your kernel flavor (pae?) and it will
install the module and the rules file. Reboot and you should be good to
go. Don't forget to uncheck the box to stay subscribed to my repository.

--
Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 3.0.13-0.27-default
up 2 days 12:31, 2 users, load average: 0.00, 0.03, 0.05
CPU Intel i5 CPU M520@2.40GHz | Intel Arrandale GPU

sharfuddin
04-Apr-2012, 19:54
which one should I select for '3.0.13-0.27-default' kernel version ?
brcmsmac-kmp-default or brcmsmac ?



Hi
Just select the 1-click for your kernel flavor (pae?) and it will
install the module and the rules file. Reboot and you should be good to
go. Don't forget to uncheck the box to stay subscribed to my repository.

--
Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 3.0.13-0.27-default
up 2 days 12:31, 2 users, load average: 0.00, 0.03, 0.05
CPU Intel i5 CPU M520@2.40GHz | Intel Arrandale GPU

malcolmlewis
04-Apr-2012, 21:33
which one should I select for '3.0.13-0.27-default' kernel version ?
brcmsmac-kmp-default or brcmsmac ?


Hi
Just brcmsmac-kmp-default and the rules one will get automatically
included.

--
Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 3.0.13-0.27-default
up 2:37, 2 users, load average: 0.11, 0.07, 0.06
CPU Intel i5 CPU M520@2.40GHz | Intel Arrandale GPU