PDA

View Full Version : xrdp error



mryo20011024
11-Aug-2017, 06:33
I installed xrdp on SLES for Raspberry Pi 12SP2.
When I tried to connect to this with xrdp, I got the error below.
/var/log/xrdp.log
[20170811-14:09:58] [CORE ] WARNING: Invalid x.509 certificate path defined, default path will be used: /etc/xrdp/key.pem
[20170811-14:11:11] [ERROR] Listening socket is in wrong state we terminate listener
[20170811-14:11:14] [CORE ] WARNING: Invalid x.509 certificate path defined, default path will be used: /etc/xrdp/cert.pem
[20170811-14:11:14] [CORE ] WARNING: Invalid x.509 certificate path defined, default path will be used: /etc/xrdp/key.pem
[20170811-14:11:31] [ERROR] Listening socket is in wrong state we terminate listener
[20170811-14:13:34] [CORE ] WARNING: Invalid x.509 certificate path defined, default path will be used: /etc/xrdp/cert.pem
[20170811-14:13:34] [CORE ] WARNING: Invalid x.509 certificate path defined, default path will be used: /etc/xrdp/key.pem
[20170811-14:25:33] [ERROR] Listening socket is in wrong state we terminate listener
[20170811-14:28:34] [CORE ] WARNING: Invalid x.509 certificate path defined, default path will be used: /etc/xrdp/cert.pem
[20170811-14:28:34] [CORE ] WARNING: Invalid x.509 certificate path defined, default path will be used: /etc/xrdp/key.pem

/var/log/xrdp-sesman.log
[20170811-14:28:34] [ERROR] env_set_user: error creating .vnc dir
[20170811-14:29:40] [ERROR] env_set_user: error creating .vnc dir

Is this bug?

Regards.

Ryo

mryo20011024
14-Aug-2017, 04:11
I found the workaround for this.
The steps are below.
1. #zypper in xrdp
2. #openssl req -x509 -newkey rsa:4096 -keyout key.pem -sha256 -nodes -out cert.pem -days 365 -subj "/CN=$(hostname)"
3. #zypper in gnome-basic
4. #systemctl enable xrdp
5. #systemctl start xrdp