PHP 7.1

ketterketter Senior Member
I am running a PHP based application on SLES 12 SP4. It uses ZipStream (https://github.com/maennchen/ZipStream-PHP). After one of the recent updates, I started having issues and it seems to be related to the PHP version. ZipStream site states that the minimum PHP version is now 7.1. My SLES 12 SP4 server is running PHP 7.0.7. Is it possible to get a newer version of PHP on SLES 12 SP4? Or do I need to upgrade the OS to something newer? Thanks!

Comments

  • malcolmlewismalcolmlewis Knowledge Partner
    ketter wrote: »
    I am running a PHP based application on SLES 12 SP4. It uses ZipStream (https://github.com/maennchen/ZipStream-PHP). After one of the recent updates, I started having issues and it seems to be related to the PHP version. ZipStream site states that the minimum PHP version is now 7.1. My SLES 12 SP4 server is running PHP 7.0.7. Is it possible to get a newer version of PHP on SLES 12 SP4? Or do I need to upgrade the OS to something newer? Thanks!
    Hi
    You need SLE >= 15 for PHP7.2.x, no 7.1....

    FYI, log in to SUSE Customer Center, on the left side 'My Tools' -> Packages is a search feature for releases/packages and versions ;)
  • ketterketter Senior Member
    Bummer, I was hoping I could just do a simple upgrade of PHP. Guess I need to find the time to move this application to SLES 15. Thanks for the quick response!

    Ken
Sign In or Register to comment.