Error upgrading SLES 12 SP4 to SLES 15.

SkyFaithSkyFaith New or Quiet Member
Hi SUSE Community,

New to the big family here, recently was tasked to upgrade the existing virtualization server of SLES 12 SP4 to SLES 15. But was met with an error after the, "Previously Used Repositories" page. The error is as follows, "Internal error: Failed to open TCP connection to scc.suse.com:443 (getaddrinfo:Name or service not known). I tried searching for some hints on the net but couldn't find anything useful. I hope the fam here could help me out.

*I have internet connection to the virtual machine on SLES 12 SP4 before running the update package:SLE-15-Installer-DVD-x86_64-GM-DVD1.iso

Much Appreciated. :)

Yy3yYCM

Comments

  • EugenEugen Senior Member
    Hi and welcome to the forum!

    Is the system registered to any repository management like SMT/RMT or SUSE Manager? During the upgrade the default way of the installer is to connect to SCC and update the repositories according to your subscriptions. It's not really optimal but one can usually work around that. Can you show the output of (please mask all sensitive data):
    SUSEConnect -s
    
    zypper lr -Ed
    

    Depending on your actual setup the SUSE Distribution Migration System might be worth looking at. But let's see your repo setup first.

    Regards,
    Eugen
Sign In or Register to comment.