SLES 15 SP1: ESXi VM, don't boot, emergency mode, XFS file systems

edited September 27 in SLES Install-Boot

Hi,
i'm very new on SLES and Linux world. I have a VM SLES 15 SP1 that works fine under Workstation ; i convert it to ESXi and now it don't work, it's a Linux error message:

I admit that from there I don't know how to do much, how I can already recover the file rdsosreport.txt, under this mode i'm limited in the orders available.
Please help :)

Comments

  • malcolmlewismalcolmlewis Knowledge Partner

    Hi
    You should be able to copy to /boot for the moment, your need the partition information, so give the root password to get to a prompt, then run for example;

    lsblk
    NAME        MAJ:MIN RM   SIZE RO TYPE MOUNTPOINT
    sda           8:0    0 232.9G  0 disk 
    ├─sda1        8:1    0   260M  0 part /boot/efi
    ├─sda2        8:2    0   768M  0 part /boot
    

    In my /boot is /dev/sda2, so

    mount /dev/sda2 /mnt
    cp /run/initramfs/rdsosreport.txt /mnt/rdsosreport.txt
    sync
    umount /mnt
    

    The sync commands just ensure everything is written out before unmounting.

    Have you tried running the repair as indicated in the output?

  • edited September 27

    Hello Malcom,

    lsblk is not available, in fact i don't have a lot of command available, it's for that's why I'm not getting through :(

    The prompt is: sh-4.4#

  • malcolmlewismalcolmlewis Knowledge Partner

    Hi
    OK, so can you reboot and see if we can get to just / mounted, at the grub prompt, press the up down arrow keys to stop the boot timer and highlight the SLES-15-SP1 prompt and press 'e' key to edit the boot stanza. Now use the 'down' arrow key to the line starting with 'linux' (or linuxefi) and press the 'end' key so the prompt is at 'low' add a space and then type in; init=/bin/bash then press the F10 key to boot the system, this should skip mount points except / and get a running system.

  • Hi,
    i don't have prompt option, just that:

    :/

  • malcolmlewismalcolmlewis Knowledge Partner

    Hi
    That's fine, edit that one and see how it goes, if no go, try just booting the next one down which is recovery mode.

  • Hi,
    for the first line the system works during about 3/4 minutes and give me the following error:

    the second line, with recovery mode give me the same error but with more details during the start:

  • malcolmlewismalcolmlewis Knowledge Partner

    Hi
    Which method used to boot? Anyway can you login with the root user password? and try lsblk?

  • it's a vmware virtual machine, maybe it comes from there? my VM is not setup correctly?
    When i create a new VM with SLES 15 SP1 i can boot without problem.
    Maybe I should see with vmware community?

  • malcolmlewismalcolmlewis Knowledge Partner

    Hi
    Perhaps the method of conversion from workstation to esxi is causing some sort of corruption.
    My question about booting your virtual machine was which method used to boot, did you edit the grub entry or did you boot from grub from the 'recovery' one? When you get to the prompt to enter the root password, you get just a # prompt or a hostname# prompt? Can you run the command lsblk do you get any output?

  • edited September 27

    When i start the VM, the first screen is about vmware:

    After:

    the SUSE screen boot:

    Finally the system don't boot:

  • edited September 27

    Prompt only with # after input password.

  • malcolmlewismalcolmlewis Knowledge Partner

    Hi
    So at the other grub screen the one you posted earlier that has the SLES boot options (the four of them), this is where you edit and add the boot option init=/bin/bash have you tried this? Or is vmware skipping the option now?

  • Hi Malcom,
    I noticed that the version of my ESXi (6.7) is not compatible with my hardware server. So i install a compatible version (6.5) and i'm going to retest it all.
    Thanks for your help.

Sign In or Register to comment.