Access denied to repository using zypper utility

Hi People how are you? I have this problem in my SuSE Linux in my Company using Zypper.
Let's see:

zypper install mc

Actualizando el servicio Legacy_Module_12_x86_64.
Actualizando el servicio SUSE_Linux_Enterprise_Server_12_SP3_x86_64.
Actualizando el servicio Web_and_Scripting_Module_12_x86_64.
Recuperando los metadatos del repositorio SLE-Module-Legacy12-Updates ..................[terminado]
Construyendo el caché del repositorio SLE-Module-Legacy12-Updates ......................[terminado]
Se ha denegado el permiso para acceder a https://updates.suse.com/SUSE/Updates/SLE-SERVER/12-SP3/x86_64/update/repodata/repomd.xml?oSE7D8LB2ixQ4Ui2vVSfIr6u_flc1RaWj88qQsXhVan5lXiP1RveHTev-dEbe56P_zUWQb6qwDu8Fm_EMtD-_JN51Eml8_PvGHGNRVBXQcumXz98guwSA5KwejMkw1HeVN3ZN2IPHTp7QWo.
¿Cancelar, reintentar o ignorar? [a/r/i/...? mostrar todas las opciones] (a):
I cant install utilities via zypper... what happened?
Thanks you a lot!

Comments

  • malcolmlewismalcolmlewis Knowledge Partner

    Hi and welcome to the Forum :)
    So the system has an active subscription?

  • Yes i have a subscription its running SAP HANA in the server.

  • malcolmlewismalcolmlewis Knowledge Partner

    Hi
    So have you tried a force on the refresh zypper ref -f? It could also be a glitch in the mirror network (CDN). Sometimes need to try a few times.

  • hi, how are you? Same problem...

    zypper ref -f

    Forzando actualización de metadatos en bruto
    Recuperando los metadatos del repositorio SLE-Module-Legacy12-Pool ..[terminado]
    Se está forzando la construcción del caché del repositorio
    Construyendo el caché del repositorio SLE-Module-Legacy12-Pool ......[terminado]
    Forzando actualización de metadatos en bruto
    Recuperando los metadatos del repositorio SLE-Module-Legacy12-Updates[terminado]
    Se está forzando la construcción del caché del repositorio
    Construyendo el caché del repositorio SLE-Module-Legacy12-Updates ...[terminado]
    Forzando actualización de metadatos en bruto
    Recuperando los metadatos del repositorio SLES12-SP3-Pool -------------------[]
    Se ha denegado el permiso para acceder a https://updates.suse.com/SUSE/Products/SLE-SERVER/12-SP3/x86_64/product/repodata/repomd.xml?n8MJO3HzmxMTD7mFM4s1KzalkZiSrTQpX7c_UpCHJt__NN1mHWs6cNEc7a-Tj0t3XsI6tVXIOS18LpJyWVDmA9RCDN5GQ_RmBgXN9ffFItgL5-EADoGzSkUeePH-lAypIsqi5oQryR3KDG3mgw.
    ¿Cancelar, reintentar o ignorar? [a/r/i/...? mostrar todas las opciones] (a):

  • malcolmlewismalcolmlewis Knowledge Partner

    Hi
    Let me ask my SUSE Contacts if something is up with the repositories.

  • HvdHeuvelHvdHeuvel Administrator

    Hello Juan Pablo,
    I am not aware of any issues with the repositories at this point in time. Can you check if things are working now ? Perhaps the have been some infra structure issues ?
    Is this a new installation or was this working before ? I just tested this on my SLES12 for SAP SP3 server and the repo's refresh properly today

    Thanks
    Hans

  • Hi, how are you? I have 2 diferents customers that have SUSE for the HANA Bussines One and have the same problem. I dont know why i have access denied.

  • Any news? I dont know why i have same problem in 2 customer with different server same version of suse linux

  • HvdHeuvelHvdHeuvel Administrator

    Hello Juan,
    Are you in the position to open a support case ?
    I am afraid the issue may be local to your (customer's) setup since it appears to generally work well on the back-end

    `
    --- cut here ---

    sles12sp3sap:~ # zypper ref
    Repository 'SLE-Module-Legacy12-Pool' is up to date.
    Repository 'SLE-Module-Legacy12-Updates' is up to date.
    Repository 'SLE-12-SP3-SAP-Updates' is up to date.
    Repository 'SLE-HA12-SP3-Pool' is up to date.
    Repository 'SLE-HA12-SP3-Updates' is up to date.
    Repository 'SLE12-SP3-SAP-Pool' is up to date.
    Repository 'SLES12-SP3-Pool' is up to date.
    Repository 'SLES12-SP3-Updates' is up to date.
    Repository 'SLE-Module-Web-Scripting12-Pool' is up to date.
    Repository 'SLE-Module-Web-Scripting12-Updates' is up to date.
    All repositories have been refreshed.
    sles12sp3sap:~ # date
    Thu Oct 22 17:20:19 CEST 2020
    sles12sp3sap:~ #
    --- cut here ---
    `
    I can refresh all repositories without any issues as we speak

    Once you have opened a ticket, can you please drop me a direct email at hvdheuvel[at]suse[dot]com with the case numbers?
    Best regards
    Hans

  • Great i will open a ticket. Thanks you!

  • Hi, how are you? Mistake are fixed the server was installed without a registration so i go to yast and i put the registration code and runs correctly. Please sorry for mistake. You can close the tread.
    Thanks a lot!

  • HvdHeuvelHvdHeuvel Administrator

    Awesome !
    You are more than welcome.
    Although it is a bit strange as the repositories you list can only be seen once the server is registered. So it seems as something happened locally on the server, but in the end, I am happy to see that you found the solution to the problem :thumbsup
    Have a wonderful day and weekend
    Hans

Sign In or Register to comment.