Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: hardware 3D stereo doesn't work

  1. #1

    Exclamation hardware 3D stereo doesn't work

    Hello,

    I am using SLED 12 SP3 SLE desktop environment. I have configure my xorg.conf as following:

    Code:
    # nvidia-xconfig: X configuration file generated by nvidia-xconfig
    # nvidia-xconfig:  version 384.98  (buildmeister@swio-display-x86-rhel47-02)  Thu Oct 26 15:56:05 PDT 2017
    
    # /.../
    # SaX generated X11 config file
    # Created on: 2014-10-22T11:38:48+0200.
    #
    # Version: 8.1
    # Contact: Marcus Schaefer <sax@suse.de>, 2005
    # Contact: SaX-User list <https://lists.berlios.de/mailman/listinfo/sax-users>
    #
    # Automatically generated by [ISaX] (8.1)
    # PLEASE DO NOT EDIT THIS FILE!
    #
    
    Section "ServerLayout"
        Identifier     "Layout[all]"
        Screen         "Screen[0]" 0 0
        InputDevice    "Keyboard[0]" "CoreKeyboard"
        InputDevice    "Mouse[1]" "CorePointer"
        Option         "Clone" "off"
        Option         "Xinerama" "off"
    EndSection
    
    Section "Files"
        InputDevices      "/dev/gpmdata"
        InputDevices      "/dev/input/mice"
        FontPath        "/usr/share/fonts/misc:unscaled"
        FontPath        "/usr/share/fonts/local"
        FontPath        "/usr/share/fonts/75dpi:unscaled"
        FontPath        "/usr/share/fonts/100dpi:unscaled"
        FontPath        "/usr/share/fonts/Type1"
        FontPath        "/usr/share/fonts/URW"
        FontPath        "/usr/share/fonts/Speedo"
        FontPath        "/usr/share/fonts/PEX"
        FontPath        "/usr/share/fonts/cyrillic"
        FontPath        "/usr/share/fonts/latin2/misc:unscaled"
        FontPath        "/usr/share/fonts/latin2/75dpi:unscaled"
        FontPath        "/usr/share/fonts/latin2/100dpi:unscaled"
        FontPath        "/usr/share/fonts/latin2/Type1"
        FontPath        "/usr/share/fonts/latin7/75dpi:unscaled"
        FontPath        "/usr/share/fonts/baekmuk:unscaled"
        FontPath        "/usr/share/fonts/japanese:unscaled"
        FontPath        "/usr/share/fonts/kwintv"
        FontPath        "/usr/share/fonts/truetype"
        FontPath        "/usr/share/fonts/uni:unscaled"
        FontPath        "/usr/share/fonts/CID"
        FontPath        "/usr/share/fonts/ucs/misc:unscaled"
        FontPath        "/usr/share/fonts/ucs/75dpi:unscaled"
        FontPath        "/usr/share/fonts/ucs/100dpi:unscaled"
        FontPath        "/usr/share/fonts/hellas/misc:unscaled"
        FontPath        "/usr/share/fonts/hellas/75dpi:unscaled"
        FontPath        "/usr/share/fonts/hellas/100dpi:unscaled"
        FontPath        "/usr/share/fonts/hellas/Type1"
        FontPath        "/usr/share/fonts/misc/sgi:unscaled"
        FontPath        "/usr/share/fonts/xtest"
        FontPath        "/opt/kde3/share/fonts"
    EndSection
    
    Section "Module"
        Load           "dbe"
        Load           "freetype"
        Load           "extmod"
        Load           "glx"
    EndSection
    
    Section "ServerFlags"
    
      # Uncomment the following option to reenable kbd/mouse driver input sections. 
      # Otherwise evdev driver is used. 
      #Option       "AutoAddDevices" "off"
        Option         "AllowMouseOpenFail" "on"
        Option         "ZapWarning" "on"
    EndSection
    
    Section "InputDevice"
        Identifier     "Keyboard[0]"
        Driver         "kbd"
        Option         "Protocol" "Standard"
        Option         "XkbLayout" "us"
        Option         "XkbModel" "microsoftpro"
        Option         "XkbRules" "xfree86"
    EndSection
    
    Section "InputDevice"
        Identifier     "Mouse[1]"
        Driver         "mouse"
        Option         "Buttons" "5"
        Option         "Device" "/dev/input/mice"
        Option         "Name" "Lenovo Optical Mouse"
        Option         "Protocol" "explorerps/2"
        Option         "Vendor" "Sysp"
        Option         "ZAxisMapping" "4 5"
    EndSection
    
    Section "Modes"
        Identifier         "Modes[0]"
    EndSection
    
    Section "Monitor"
        Identifier     "Monitor[0]"
        VendorName     "--> VESA"
        ModelName      "800X600@60HZ"
        UseModes       "Modes[0]"
        HorizSync       31.0 - 94.0
        VertRefresh     50.0 - 75.0
        Option         "CalcAlgorithm" "XServerPool"
        Option         "DPMS"
    EndSection
    
    Section "Device"
        Identifier     "Device[0]"
        Driver         "nvidia"
        VendorName     "VESA"
        BoardName      "Framebuffer Graphics"
    EndSection
    
    Section "Screen"
        Identifier     "Screen[0]"
        Device         "Device[0]"
        Monitor        "Monitor[0]"
        DefaultDepth    24
        Option         "nvidiaXineramaInfoOrder" "DFP-0"
        Option         "metamodes" "1920x1080_120 +0+0"
        Option         "SLI" "Off"
        Option         "MultiGPU" "Off"
        Option         "BaseMosaic" "off"
        Option         "Stereo" "11"
        Option         "Composite" "Disable"
        SubSection     "Display"
            Depth       24
            Modes      "default"
        EndSubSection
    EndSection

    I am trying to visualize some images with Nvidia hardware stereo, but it doesn't work. This works perfectly in my openSUSE 13.2 previously in the same machine.

    Does any body have any idea how to fix this problem?

    Thanks a lot.

  2. Re: hardware 3D stereo doesn't work

    On Mon 13 Nov 2017 07:44:02 AM CST, albumns wrote:

    Hello,

    I am using SLED 12 SP3 SLE desktop environment. I have configure my
    xorg.conf as following:


    Code:
    --------------------

    # nvidia-xconfig: X configuration file generated by nvidia-xconfig
    # nvidia-xconfig: version 384.98
    (buildmeister@swio-display-x86-rhel47-02) Thu Oct 26 15:56:05 PDT 2017
    # /.../
    # SaX generated X11 config file
    # Created on: 2014-10-22T11:38:48+0200.
    #
    # Version: 8.1
    # Contact: Marcus Schaefer <sax@suse.de>, 2005
    # Contact: SaX-User list
    <https://lists.berlios.de/mailman/listinfo/sax-users> #
    # Automatically generated by [ISaX] (8.1)
    # PLEASE DO NOT EDIT THIS FILE!
    #

    Section "ServerLayout"
    Identifier "Layout[all]"
    Screen "Screen[0]" 0 0
    InputDevice "Keyboard[0]" "CoreKeyboard"
    InputDevice "Mouse[1]" "CorePointer"
    Option "Clone" "off"
    Option "Xinerama" "off"
    EndSection

    Section "Files"
    InputDevices "/dev/gpmdata"
    InputDevices "/dev/input/mice"
    FontPath "/usr/share/fonts/misc:unscaled"
    FontPath "/usr/share/fonts/local"
    FontPath "/usr/share/fonts/75dpi:unscaled"
    FontPath "/usr/share/fonts/100dpi:unscaled"
    FontPath "/usr/share/fonts/Type1"
    FontPath "/usr/share/fonts/URW"
    FontPath "/usr/share/fonts/Speedo"
    FontPath "/usr/share/fonts/PEX"
    FontPath "/usr/share/fonts/cyrillic"
    FontPath "/usr/share/fonts/latin2/misc:unscaled"
    FontPath "/usr/share/fonts/latin2/75dpi:unscaled"
    FontPath "/usr/share/fonts/latin2/100dpi:unscaled"
    FontPath "/usr/share/fonts/latin2/Type1"
    FontPath "/usr/share/fonts/latin7/75dpi:unscaled"
    FontPath "/usr/share/fonts/baekmuk:unscaled"
    FontPath "/usr/share/fonts/japanese:unscaled"
    FontPath "/usr/share/fonts/kwintv"
    FontPath "/usr/share/fonts/truetype"
    FontPath "/usr/share/fonts/uni:unscaled"
    FontPath "/usr/share/fonts/CID"
    FontPath "/usr/share/fonts/ucs/misc:unscaled"
    FontPath "/usr/share/fonts/ucs/75dpi:unscaled"
    FontPath "/usr/share/fonts/ucs/100dpi:unscaled"
    FontPath "/usr/share/fonts/hellas/misc:unscaled"
    FontPath "/usr/share/fonts/hellas/75dpi:unscaled"
    FontPath "/usr/share/fonts/hellas/100dpi:unscaled"
    FontPath "/usr/share/fonts/hellas/Type1"
    FontPath "/usr/share/fonts/misc/sgi:unscaled"
    FontPath "/usr/share/fonts/xtest"
    FontPath "/opt/kde3/share/fonts"
    EndSection

    Section "Module"
    Load "dbe"
    Load "freetype"
    Load "extmod"
    Load "glx"
    EndSection

    Section "ServerFlags"

    # Uncomment the following option to reenable kbd/mouse driver input
    sections. # Otherwise evdev driver is used.
    #Option "AutoAddDevices" "off"
    Option "AllowMouseOpenFail" "on"
    Option "ZapWarning" "on"
    EndSection

    Section "InputDevice"
    Identifier "Keyboard[0]"
    Driver "kbd"
    Option "Protocol" "Standard"
    Option "XkbLayout" "us"
    Option "XkbModel" "microsoftpro"
    Option "XkbRules" "xfree86"
    EndSection

    Section "InputDevice"
    Identifier "Mouse[1]"
    Driver "mouse"
    Option "Buttons" "5"
    Option "Device" "/dev/input/mice"
    Option "Name" "Lenovo Optical Mouse"
    Option "Protocol" "explorerps/2"
    Option "Vendor" "Sysp"
    Option "ZAxisMapping" "4 5"
    EndSection

    Section "Modes"
    Identifier "Modes[0]"
    EndSection

    Section "Monitor"
    Identifier "Monitor[0]"
    VendorName "--> VESA"
    ModelName "800X600@60HZ"
    UseModes "Modes[0]"
    HorizSync 31.0 - 94.0
    VertRefresh 50.0 - 75.0
    Option "CalcAlgorithm" "XServerPool"
    Option "DPMS"
    EndSection

    Section "Device"
    Identifier "Device[0]"
    Driver "nvidia"
    VendorName "VESA"
    BoardName "Framebuffer Graphics"
    EndSection

    Section "Screen"
    Identifier "Screen[0]"
    Device "Device[0]"
    Monitor "Monitor[0]"
    DefaultDepth 24
    Option "nvidiaXineramaInfoOrder" "DFP-0"
    Option "metamodes" "1920x1080_120 +0+0"
    Option "SLI" "Off"
    Option "MultiGPU" "Off"
    Option "BaseMosaic" "off"
    Option "Stereo" "11"
    Option "Composite" "Disable"
    SubSection "Display"
    Depth 24
    Modes "default"
    EndSubSection
    EndSection


    --------------------



    I am trying to visualize some images with Nvidia hardware stereo, but it
    doesn't work. This works perfectly in my openSUSE 13.2 previously in the
    same machine.

    Does any body have any idea how to fix this problem?

    Thanks a lot.


    Hi
    You need to make your modifications down in /etc/X11/xorg.conf.d so
    dump that file and use a configuration file in the directory above.

    For example I have a 50-nvidia.conf file containing;
    Code:
    cat /etc/X11/xorg.conf.d/50-nvidia.conf
    
    Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce 8800 GT"
    Option         "Coolbits" "5"
    Option         "NoLogo" "1"
    EndSection
    Where are you installing the nvidia driver from?

    --
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    openSUSE Leap 42.2|GNOME 3.20.2|4.4.92-18.36-default
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!


  3. #3

    Unhappy Re: hardware 3D stereo doesn't work

    I download the driver from Nvidia official.

    There are many .conf files, I don't know which should I modify......

    > ls /etc/X11/xorg.conf.d/
    00-keyboard.conf 10-quirks.conf 50-elotouch.conf 50-screen.conf
    10-evdev.conf 11-evdev.conf 50-extensions.conf 50-synaptics.conf
    10-libvnc.conf 50-device.conf 50-monitor.conf



    Quote Originally Posted by malcolmlewis View Post
    Hi
    You need to make your modifications down in /etc/X11/xorg.conf.d so
    dump that file and use a configuration file in the directory above.

    For example I have a 50-nvidia.conf file containing;
    Code:
    cat /etc/X11/xorg.conf.d/50-nvidia.conf
    
    Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce 8800 GT"
    Option         "Coolbits" "5"
    Option         "NoLogo" "1"
    EndSection
    Where are you installing the nvidia driver from?

    --
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    openSUSE Leap 42.2|GNOME 3.20.2|4.4.92-18.36-default
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  4. #4

    Re: hardware 3D stereo doesn't work

    btw,

    I just noticed that the Nvidia Stereo effect works in my MATE desktop environment, but it doesn't work in either KDE, GNOME or SLE environments. I Googled, it said that the other desktop environments introduced so called "Compositing" feature which disabled Nvidia stereo property......Is it possible to disable this "Compositing" function under SLE environment so that we can also use Nvidia stereo?

    thanks again

  5. Re: hardware 3D stereo doesn't work

    Quote Originally Posted by albumns View Post
    btw,

    I just noticed that the Nvidia Stereo effect works in my MATE desktop environment, but it doesn't work in either KDE, GNOME or SLE environments. I Googled, it said that the other desktop environments introduced so called "Compositing" feature which disabled Nvidia stereo property......Is it possible to disable this "Compositing" function under SLE environment so that we can also use Nvidia stereo?

    thanks again
    Hi
    You need to create the 50-nvidia.conf file I indicated manually, for compositing, edit the /etc/X11/xorg.conf.d/50-extensions.conf and add;
    Code:
    Option         "Composite" "Disable"
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  6. Re: hardware 3D stereo doesn't work

    Hi
    Seems like in the 50-nvidia.conf file you need;
    Code:
    Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "Your Card Name"
    Option         "AllowDFPStereo" "1"
    Option         "UBB" "1"
    Option         "Stereo" "10"
    EndSection
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  7. #7

    Re: hardware 3D stereo doesn't work

    Hello, I first deleted the xorg.conf file at:

    /etc/X11

    Then, I created a 50-nvidia.conf file to
    /etc/X11/xorg.conf.d

    Here is the content of the above file

    Code:
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "Framebuffer Graphics"
    Option         "AllowDFPStereo" "1"
    Option         "UBB" "1"
    Option         "Stereo" "10"
    EndSection
    I also edited the 50-extension.conf file in the same directory as following:

    Code:
    Section "Extensions"
      Option "XFree86-DGA" "Disable"
      Option  "Composite" "Disable"
    EndSection
    After that, I reboot my system. Unfortunately, I was stacked in the login screen:

    It gave me a white screen with a warning messages:

    Code:
    "A problem has occrured and the system can't recover. Please logout and try again"
    thanks again.
    Last edited by albumns; 17-Nov-2017 at 09:52.

  8. Re: hardware 3D stereo doesn't work

    Quote Originally Posted by albumns View Post
    Hello, I first deleted the xorg.conf file at:

    /etc/X11

    Then, I created a 50-nvidia.conf file to
    /etc/X11/xorg.conf.d

    Here is the content of the above file

    Code:
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "Framebuffer Graphics"
    Option         "AllowDFPStereo" "1"
    Option         "UBB" "1"
    Option         "Stereo" "10"
    EndSection
    I also edited the 50-extension.conf file in the same directory as following:

    Code:
    Section "Extensions"
      Option "XFree86-DGA" "Disable"
      Option  "Composite" "Disable"
    EndSection
    After that, I reboot my system. Unfortunately, I was stacked in the login screen:

    It gave me a white screen with a warning messages:

    Code:
    "A problem has occrured and the system can't recover. Please logout and try again"
    thanks again.
    Hi
    Can you confirm the nvidia driver is in use?
    Code:
    /sbin/lspci -nnk | egrep -A3 "VGA|Display|3D"
    Can you also upload your /var/log/Xorg.log.0 to http://paste.opensuse.org/ and set to never expire please.
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  9. #9

    Re: hardware 3D stereo doesn't work

    Hi, here it is:

    Code:
    /home/albert> /sbin/lspci -nnk | egrep -A3 "VGA|Display|3D"
    03:00.0 VGA compatible controller [0300]: NVIDIA Corporation GK104GL [Quadro K5000] [10de:11ba] (rev a1)
    	Subsystem: NVIDIA Corporation Device [10de:0965]
    	Kernel driver in use: nvidia
    	Kernel modules: nouveau, nvidia_drm, nvidia

    Code:
    /home/albert> ls  /var/log/Xorg.log.0
    ls: cannot access '/var/log/Xorg.log.0': No such file or directory
    Quote Originally Posted by albumns View Post
    Hello, I first deleted the xorg.conf file at:

    /etc/X11

    Then, I created a 50-nvidia.conf file to
    /etc/X11/xorg.conf.d

    Here is the content of the above file

    Code:
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "Framebuffer Graphics"
    Option         "AllowDFPStereo" "1"
    Option         "UBB" "1"
    Option         "Stereo" "10"
    EndSection
    I also edited the 50-extension.conf file in the same directory as following:

    Code:
    Section "Extensions"
      Option "XFree86-DGA" "Disable"
      Option  "Composite" "Disable"
    EndSection
    After that, I reboot my system. Unfortunately, I was stacked in the login screen:

    It gave me a white screen with a warning messages:

    Code:
    "A problem has occrured and the system can't recover. Please logout and try again"
    thanks again.

  10. Re: hardware 3D stereo doesn't work

    Quote Originally Posted by albumns View Post
    Code:
    /home/albert> ls  /var/log/Xorg.log.0 /var/log/Xorg
    ls: cannot access '/var/log/Xorg.log.0': No such file or directory
    Hi
    Oops, try /var/log/Xorg.0.log
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •