Results 1 to 3 of 3

Thread: New SLES 12 SP3 EC2 AMI network scripts issues

  1. #1

    Exclamation New SLES 12 SP3 EC2 AMI network scripts issues

    Launching new suse-sles-12-sp3-v20171107-hvm-ssd-x86_64 (ami-518b2628) within a private subnet (ie no public IP allocation), AMI located in Region eu-west-1, results in the network config script for eth0 being set to manual start:

    BOOTPROTO=dhcp
    MTU=9000
    REMOTE_IPADDR=
    STARTMODE=manual
    CLOUD_NETCONFIG_MANAGE=yes
    USERCONTROL=no
    ETHTOOL_OPTIONS=

    The network will start on the first launch but fail on subsequent restarts or stop and starts since the script is set to manual. This only happens when the instance is launched without a public IP (within a private subnet).

    Output of cloud-init.log where config is applied:

    2017-11-19 05:57:29,742 - stages.py[INFO]: Applying network configuration from ds bringup=True: {'version': 1, 'config': [{'subnets': [], 'type': 'physical', 'name': 'eth0', 'mac_address': '06:9d:49:56:d4:d8'}]}
    iface eth0 inet manual
    into {'lo': {'auto': True, 'ipv6': {}}, 'eth0': {'ipv6': {}}}

    Also noticed the following error in the cloud-init-output.log:

    2017-11-19 06:44:32,421 - __init__.py[WARNING]: apply_network_config is not currently implemented for distribution '<class 'cloudinit.distros.sles.Distro'>'. Attempting to use apply_network

    Downgraded cloud-init to version 7.9 on the instance and created a new AMI, this works fine and the network script is set to STARTMODE=onboot, also no error in cloud-init-output.log. Since this happens on the new Quick start AMI on EC2 I believe a lot of people will be affected. Please fix asap.

  2. Re: New SLES 12 SP3 EC2 AMI network scripts issues

    Thanks for reporting and apologies for this slipping through the cracks. A solution is being worked on. This thread will be updated when new images have been released.

    There appears to be a race condition where the Ec2 data provider in cloud-init is not properly reporting the network.

  3. Re: New SLES 12 SP3 EC2 AMI network scripts issues

    New AMIs have been published:

    Name in all regions: suse-sles-12-sp3-v20171121-hvm-ssd-x86_64

    Here are the AMI-IDs per region:

    ami-69df0d04 -> cn-north-1
    ami-7377fb12 -> us-gov-west-1
    ami-6b4cc411 -> us-east-1
    ami-36f5db53 -> us-east-2
    ami-0eebd36e -> us-west-1
    ami-e3ef329b -> us-west-2
    ami-adc974cb -> ap-northeast-1
    ami-f067c09e -> ap-northeast-2
    ami-2cacfb4f -> ap-southeast-1
    ami-7eb15b1c -> ap-southeast-2
    ami-d6e2adb9 -> ap-south-1
    ami-438a3127 -> ca-central-1
    eu-central-1 -> ami-b08406df
    ami-6fd16616 -> eu-west-1
    ami-c4c2dda0 -> eu-west-2
    ami-548bce38 -> sa-east-1

    pint data will follow tomorrow once other images affected by this issue have been updated.

    Request to update the Quick Launcher images has been made and it is expected that the Quick Launcher will be updated sometime tomorrow.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •