Quote Originally Posted by ashbyj
malcolmlewis;4694 Wrote:
>
> I would guess the filesystem containing the libraries has not been
> mounted at that point hence it can't find them (/dev/sda1).....
>
> When your at that prompt, what is mounted? (just run the mount
> command).
>


This is what the mount command returns at that bash prompt (after
Alt+SysRq+c is pressed):


Code:
--------------------

bash-3.2# mount
proc on /proc type proc (rw)
sysfs on /sys type sysfs (rw)
udev on /dev type tmpfs (rw,mode=0755,nr_inodes=0)
tmpfs on /dev/shm type tmpfs (rw,mod=1777)
devpts on /dev/pts type devpts (rw,mode=0620,gid=5)
/dev/sda1 on /root type ext3 (rw,acl,user_xattr)
bash-3.2#

--------------------


malcolmlewis;4694 Wrote:
>
> The dmesg command may offer further information. In you VM if you can
> get to tty10 (ctrl+alt+F10) it has kernel messages.
>


Cool, I did not know about tty10. I think its just Alt+F# in VMWare
though to switch terminals. I was unable to get to tty10 when at the
bash prompt though. After doing "exit" it seems to finish booting OK
and then I'm at the normal login prompt - I'm not sure if this is a
kexec/kdump kernel it puts me in or what kernel I'm presented a login
prompt for? Anyway, I'm able to get to tty10 at that point, but its
past the shared lib error messages I was interested in.



malcolmlewis;4694 Wrote:
>
> I would guess that /dev/sdb1 is you swap partition (and for resume),
> so
> why would it being resuming, sure the systems are not going into a
> power management mode (seem to be frozen). I would have thought
> anything related to power saving would be disabled?
>


Correct, /dev/sdb1 is swap and the setting for resume. Ya know, I've
never questioned the "resume" kernel option. If its for hibernating or
suspending a system for power-saving reasons, I guess I don't need it?
Its a server, hence the reason we run SLES.

Hi
So /dev/sda1 is mounted as /root (the user) not / hence it can't find
the libraries. Unless there are directories under /root?

What does the mount command say when all back and running?

Maybe a browse through the system BIOS may add some additional
information on any power saving features that are enabled?

AFAIK anything power related should be disabled, check down in /etc/pm
and /etc/pm-profiler if they exist.

--
Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 12.1 (x86_64) Kernel 3.1.10-1.9-desktop
up 5 days 19:40, 4 users, load average: 0.00, 0.02, 0.05
CPU Intel i5 CPU M520@2.40GHz | Intel Arrandale GPU