Our application is moving from SLES10 SP2 to SLES11 SP1. When running
stability test for 4 days, VIRT of some processes can jump 64M
sometimes. But Res doesn't change. I am not sure whether it is memory
leak.
When I check by pmap, I find that all of increased 64M are [anon]. I
can confirm our application will not alloc 64M memory one time.

Pmap output when process is starting:

START SIZE RSS PSS DIRTY SWAP PERM MAPPING
0000000000400000 2548K 1112K 1112K 0K 0K r-xp /opt/***
000000000087c000 84K 52K 52K 24K 0K r--p /opt/***
0000000000891000 304K 24K 24K 12K 0K rw-p /opt/***
00000000008dd000 908K 880K 880K 880K 0K rw-p [heap]
00007f006196a000 4K 0K 0K 0K 0K ---p [anon]
00007f006196b000 8192K 12K 12K 12K 0K rwxp [anon]
00007f006216b000 4K 0K 0K 0K 0K ---p [anon]
00007f006216c000 8192K 8K 8K 8K 0K rwxp [anon]
00007f006296c000 4K 0K 0K 0K 0K ---p [anon]
00007f006296d000 8192K 8K 8K 8K 0K rwxp [anon]
00007f006316d000 4K 0K 0K 0K 0K ---p [anon]
.....................

pmap output when process is running for some time:

START SIZE RSS PSS DIRTY SWAP PERM MAPPING
0000000000400000 2548K 1112K 1112K 0K 0K r-xp /opt/***
000000000087c000 84K 52K 52K 24K 0K r--p /opt/***
0000000000891000 304K 24K 24K 12K 0K rw-p /opt/***
00000000008dd000 908K 880K 880K 880K 0K rw-p [heap]
00007f0054000000 132K 24K 24K 24K 0K rw-p [anon]
00007f0054021000 65404K 0K 0K 0K 0K ---p [anon]
00007f005c000000 132K 44K 44K 44K 0K rw-p [anon]
00007f005c021000 65404K 0K 0K 0K 0K ---p [anon]
00007f006196a000 4K 0K 0K 0K 0K ---p [anon]
00007f006196b000 8192K 12K 12K 12K 0K rwxp [anon]
00007f006216b000 4K 0K 0K 0K 0K ---p [anon]
00007f006216c000 8192K 8K 8K 8K 0K rwxp [anon]
00007f006296c000 4K 0K 0K 0K 0K ---p [anon]


It seems that some 65404 anonymous occurs


--
greencacti
------------------------------------------------------------------------
greencacti's Profile: http://forums.novell.com/member.php?userid=116080
View this thread: http://forums.novell.com/showthread.php?t=443980