Results 1 to 7 of 7

Thread: Upgrading SLES 11 SP2 to 11 SP4 - no partitions

Hybrid View

  1. Upgrading SLES 11 SP2 to 11 SP4 - no partitions

    So I went to update the server to SLES 11 SP4 from SLES 11 SP2. On other servers, when I have started the upgrade process, it normally will show the root partition that it wants to install to. This time, it said it couldn't find a root partition. When I look in Expert Partitioner in YAST, the root partition shows up under 'system' which is under 'Volume Management'. Is this an LVM setup?

    Do I have to tell the installation program to show all partitions then somehow try to find this under the volume management? I have never dealt with LVM volumes before.

    Thanks,

    Dan

  2. Re: Upgrading SLES 11 SP2 to 11 SP4 - no partitions

    Hi Dan,

    just want to confirm that you're dealing with LVM there. It looks as if you have a volume group named "system".

    I do not recall having had problems upgrading SLES11 SP3 to SP4, while using LVM. Have you skipped that intermediate step? If so, you might try the supported route and first upgrade to SP3...

    Regards,
    Jens
    Last edited by jmozdzen; 12-Feb-2018 at 17:12. Reason: typo corrected
    From the times when today's "old school" was "new school"

    If you find this post helpful and are logged into the web interface, show your appreciation and click on the star below...

  3. Re: Upgrading SLES 11 SP2 to 11 SP4 - no partitions

    Jens, thanks for the reply. What should I look for in Partitioner to determine if this is an LVM setup? Unfortunately I am not familiar with how LVM sets up partitions. What I see in partitioner is as follows:

    ServerName
    Hard Disks
    sda
    sda1
    sda2
    RAID
    Volume Management
    system
    root
    swap
    tmp

    I don't know if that helps or not.

    You think I should first upgrade from SLES 11 SP2 to SLES 11 SP3, then to SP4? What if I don't see the root partition listed in the SLES 11 SP3 installation process? I didn't realize that I could not upgrade directly from SLES 11 SP2 to SLES 11 SP4.

    Dan

  4. Re: Upgrading SLES 11 SP2 to 11 SP4 - no partitions

    Hi Dan,

    > What should I look for in Partitioner to determine if this is an LVM setup?

    this *is* an LVM setup. Your volume group is named "system" and it has four logical volumes, named to their respective intended use. Sorry that I was unclear in my earlier statement.

    > You think I should first upgrade from SLES 11 SP2 to SLES 11 SP3, then to SP4?

    See https://www.suse.com/documentation/s...rep_paths.html. Skipping intermediate SPs has been introduced with SLES12, but you're not there, yet

    > What if I don't see the root partition listed in the SLES 11 SP3 installation process?

    Let's handle that once you have tried and came across this problem again It may well be that the (SP4) upgrade is looking for an existing SP3 installation and doesn't accept the existing SP2, hence not showing any upgradable partition. If true, SP3 should well offer you to upgrade the SP2 installation...

    Regards,
    Jens
    From the times when today's "old school" was "new school"

    If you find this post helpful and are logged into the web interface, show your appreciation and click on the star below...

  5. Re: Upgrading SLES 11 SP2 to 11 SP4 - no partitions

    Thanks. I did not realize that it was not supported to go from SLES 11 SP2 to SLES 11 SP4 directly. I'll try upgrading to SLES 11 SP3 first.

    Thanks for the quick replies. I really appreciate it.

    dan

  6. Re: Upgrading SLES 11 SP2 to 11 SP4 - no partitions

    So, my bad, the server is at SLES 11 SP3. When I try to do the upgrade to SLES 11 SP4 and get to the part about picking the root partition, I get the error "The architecture of the system installed in the selected partition is different from the one of this product."

    What does that mean?

    Dan

  7. Re: Upgrading SLES 11 SP2 to 11 SP4 - no partitions

    Quote Originally Posted by dchunt View Post
    So, my bad, the server is at SLES 11 SP3. When I try to do the upgrade to SLES 11 SP4 and get to the part about picking the root partition, I get the error "The architecture of the system installed in the selected partition is different from the one of this product."

    What does that mean?

    Dan
    Hi
    Trying to install 32bit onto 64bit or the other way (or another arch ppc, s390 etc)... what is the hardware and output from the command uname -a
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •