Results 1 to 10 of 11

Thread: state.orch ceph.stage.discovery does not collect HDD info

Threaded View

  1. #1

    state.orch ceph.stage.discovery does not collect HDD info

    Hi,

    I have four nodes (1x admin, 3x osd, mons,..) prepared for the CEPH cluster.
    For some reason discovery stage does not create templates for the osd nodes.

    stage.0 completes successfully.
    stage.1 completes successfully but osd templates are missing:

    Code:
    # ls -la profile-default/stack/default/ceph/minions/
    total 0
    drwxr-xr-x 1 salt salt  0 Mar 13 16:03 .
    drwxr-xr-x 1 salt salt 14 Mar 13 16:03 ..
    Code:
    # ls -la profile-default/cluster/
    total 0
    drwxr-xr-x 1 salt salt  0 Mar 13 16:03 .
    drwxr-xr-x 1 salt salt 38 Mar 13 16:03 ..
    Deepsea monitor output for stage.1:
    Code:
    Starting stage: ceph.stage.1
    Parsing ceph.stage.1 steps... ✓
    
    
    Stage initialization output:
    salt-api                 : valid
    deepsea_minions          : valid
    master_minion            : valid
    ceph_version             : valid
    
    [1/4]     minions.ready(timeout=300)................................. ✓ (0.4s)
    
    [2/4]     ceph.refresh on
              tw-ceph-admin.............................................. ✓ (0.3s)
    
    [3/4]     populate.proposals......................................... ✓ (5s)
    
    [4/4]     proposal.populate.......................................... ✓ (1s)
    
    Ended stage: ceph.stage.1 succeeded=4/4 time=28.3s
    Master can see all minions:
    Code:
    # salt-key -L
    Accepted Keys:
    tw-ceph-admin
    tw-ceph-node1
    tw-ceph-node2
    tw-ceph-node3
    Denied Keys:
    Unaccepted Keys:
    Rejected Keys:
    All (pretended to be) osd nodes have per 3 unformated hdd:
    Code:
    # lsblk
    NAME   MAJ:MIN RM   SIZE RO TYPE MOUNTPOINT
    sda      8:0    1 136.6G  0 disk 
    ├─sda1   8:1    1     7M  0 part 
    ├─sda2   8:2    1     2G  0 part [SWAP]
    └─sda3   8:3    1 134.6G  0 part /
    sdb      8:16   1 136.6G  0 disk 
    sdc      8:32   1 136.6G  0 disk 
    sr0     11:0    1  1024M  0 rom
    Please assist to find out what am I doing wrong?

    Additional info:
    Code:
    # lsb_release -a
    LSB Version:	n/a
    Distributor ID:	SUSE
    Description:	SUSE Linux Enterprise Server 12 SP3
    Release:	12.3
    Codename:	n/a
    Code:
    # zypper se -s --installed-only | grep ses-release
    i+ | ses-release                                | package     | 5-1.54                                  | x86_64 | SES5                             
    i+ | ses-release                                | package     | 5-1.54                                  | x86_64 | SUSE-Enterprise-Storage-5-Pool   
    i  | ses-release-cd                             | package     | 5-1.54                                  | x86_64 | SES5
    Weird warning:
    Code:
    salt-master[28198]: [WARNING ] Although 'dmidecode' was found in path, the current user cannot execute it. Grains output might not be accurate.
    Firewall stopped, apparmor disabled.


    brg,
    Serhiy.
    Last edited by vazaari; 13-Mar-2018 at 15:54.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •