Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Trouble adding registering first client

Hybrid View

  1. #1

    Question Trouble adding registering first client

    I followed the direction in the getting started guide and I am having trouble. Only different is that I am not registering the client we created in the guide. I am registering a client in my job's staging environment.

    I ran the command: cat bootstrap-sles12-sp1.sh \ | ssh user@123.456.789.123 "sudo su - root"

    The above was done because the user I am using has root priv and it isn't just the root user. Then the output I get is this:

    cat: ' ': No such file or directory
    Password:
    Password:
    SUSE Manager Server Client bootstrap script v4.0


    MINOR MANUAL EDITING OF THIS FILE MAY BE REQUIRED!

    If this bootstrap script was created during the initial installation
    of a SUSE Manager Server, the ACTIVATION_KEYS, and ORG_GPG_KEY values will
    probably *not* be set (see below). If this is the case, please do the
    following:
    - copy this file to a name specific to its use.
    (e.g., to bootstrap-SOME_NAME.sh - like bootstrap-web-servers.sh.)
    - on the website create an activation key or keys for the system(s) to
    be registered.
    - edit the values of the VARIABLES below (in this script) as
    appropriate:
    - ACTIVATION_KEYS needs to reflect the activation key(s) value(s)
    from the website. XKEY or XKEY,YKEY
    Please note that if you are using this script to boostrap minions,
    only the FIRST activation key will be used. Multiple activation keys
    are not supported with salt
    - ORG_GPG_KEY needs to be set to the name(s) of the corporate public
    GPG key filename(s) (residing in /srv/www/htdocs/pub) if appropriate. XKEY or XKEY,YKEY

    Verify that the script variable settings are correct:
    - CLIENT_OVERRIDES should be only set differently if a customized
    client-config-overrides-VER.txt file was created with a different
    name.
    - ensure the value of HOSTNAME is correct.
    - ensure the value of ORG_CA_CERT is correct.

    Enable this script: comment (with #'s) this block (or, at least just
    the exit below, if present)

    hostname: Name or service not known
    -bash: line 139: [: ==: unary operator expected

    UPDATING RHN_REGISTER/UP2DATE CONFIGURATION FILES
    -------------------------------------------------
    * downloading necessary files
    client_config_update.py...
    2018-04-05 08:15:34 URL:https://af3a1susmgmt01n.domain.com/p...nfig_update.py [6483/6483] -> "client_config_update.py" [1]
    FINISHED --2018-04-05 08:15:34--
    Total wall clock time: 0.04s
    Downloaded: 1 files, 6.3K in 0s (158 MB/s)
    client-config-overrides.txt...
    2018-04-05 08:15:34 URL:https://af3a1susmgmt01n.domain.com/p...-overrides.txt [649/649] -> "client-config-overrides.txt" [1]
    FINISHED --2018-04-05 08:15:34--
    Total wall clock time: 0.03s
    Downloaded: 1 files, 649 in 0s (390 MB/s)

    PREPARE GPG KEYS AND CORPORATE PUBLIC CA CERT
    -------------------------------------------------
    * no organizational GPG keys to import

    * attempting to install corporate public CA cert
    2018-04-05 08:15:34 URL:https://af3a1susmgmt01n.domain.com/p...0-1.noarch.rpm [9495/9495] -> "rhn-org-trusted-ssl-cert-1.0-1.noarch.rpm" [1]
    FINISHED --2018-04-05 08:15:34--
    Total wall clock time: 0.03s
    Downloaded: 1 files, 9.3K in 0s (56.1 MB/s)
    Preparing... ########################################
    Updating / installing...
    rhn-org-trusted-ssl-cert-1.0-1 ########################################

    CHECKING THE REGISTRATION STACK
    -------------------------------------------------
    * check for necessary packages being installed...
    * client codebase is sle-12-sp1
    package spacewalk-check is not installed
    package spacewalk-client-setup is not installed
    package spacewalk-client-tools is not installed
    package zypp-plugin-spacewalk is not installed
    https://af3a1susmgmt01n.domain.com/p...ta/repomd.xml:
    2018-04-05 08:15:36 ERROR 404: Not Found.
    Bootstrap repo 'https://af3a1susmgmt01n.domain.com/pub/repositories/sle/12/1/bootstrap' does not exist.
    * going to install missing packages...
    /repodata/repomd.xml: Scheme missing.
    Bootstrap repo '' does not exist.
    Repository 'susemanager:bootstrap' not found by its alias, number, or URI.
    Use 'zypper repos' to get the list of defined repositories.
    Warning: Specified repositories are not enabled or defined.
    Use 'zypper addrepo' or 'zypper modifyrepo' commands to add or enable repositories.
    Refreshing service 'SUSE_Linux_Enterprise_Server_for_SAP_Applications _12_SP1_x86_64'.
    Loading repository data...
    Reading installed packages...
    'spacewalk-check' not found in package names. Trying capabilities.
    'spacewalk-client-setup' not found in package names. Trying capabilities.
    'spacewalk-client-tools' not found in package names. Trying capabilities.
    'zypp-plugin-spacewalk' not found in package names. Trying capabilities.
    No provider of 'spacewalk-check' found.
    No provider of 'spacewalk-client-setup' found.
    No provider of 'spacewalk-client-tools' found.
    No provider of 'zypp-plugin-spacewalk' found.
    package spacewalk-check is not installed
    ERROR: Failed to install all missing packages.



    Any tips there?

  2. Re: Trouble adding registering first client

    Hi
    Did you create the bootstrap repository, eg?
    Code:
    mgr-create-bootstrap-repo -l
    mgr-create-bootstrap-repo -c SLE-12-SP1-x86_64
    Your error;
    Code:
    Bootstrap repo 'https://af3a1susmgmt01n.domain.com/pub/repositories/sle/12/1/bootstrap' does not exist.
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  3. #3

    Re: Trouble adding registering first client

    Thanks for the tip. I fixed that problem. Now I'm still getting the errors on the last chunk of read outs.

    Reading installed packages...
    'spacewalk-check' not found in package names. Trying capabilities.
    'spacewalk-client-setup' not found in package names. Trying capabilities.
    No provider of 'spacewalk-check' found.
    No provider of 'spacewalk-client-setup' found.
    'spacewalk-client-tools' not found in package names. Trying capabilities.
    'zypp-plugin-spacewalk' not found in package names. Trying capabilities.
    No provider of 'spacewalk-client-tools' found.
    No provider of 'zypp-plugin-spacewalk' found.
    package spacewalk-check is not installed
    ERROR: Failed to install all missing packages.

    Is this something I am supposed to install manually on the client machine? Or is there a repo I am missing since I see it says "No provider of ........"

  4. Re: Trouble adding registering first client

    Quote Originally Posted by clydeprice View Post
    Thanks for the tip. I fixed that problem. Now I'm still getting the errors on the last chunk of read outs.

    Reading installed packages...
    'spacewalk-check' not found in package names. Trying capabilities.
    'spacewalk-client-setup' not found in package names. Trying capabilities.
    No provider of 'spacewalk-check' found.
    No provider of 'spacewalk-client-setup' found.
    'spacewalk-client-tools' not found in package names. Trying capabilities.
    'zypp-plugin-spacewalk' not found in package names. Trying capabilities.
    No provider of 'spacewalk-client-tools' found.
    No provider of 'zypp-plugin-spacewalk' found.
    package spacewalk-check is not installed
    ERROR: Failed to install all missing packages.

    Is this something I am supposed to install manually on the client machine? Or is there a repo I am missing since I see it says "No provider of ........"
    Hi
    Well that should all come from the bootstrap directory, do the files exist in /srv/www/htdocs/pub/repositories/sle/12/1/bootstrap/x86_64/

    I'm guessing your SuMA instance is all up to date as well....?
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  5. #5

    Re: Trouble adding registering first client

    Dangit....apparently not. I'll work on that. Not sure what that wouldn't be there. the /x86_64 directory isn't there.

  6. Re: Trouble adding registering first client

    On Tue 10 Apr 2018 01:24:02 PM CDT, clydeprice wrote:

    Dangit....apparently not. I'll work on that. Not sure what that wouldn't
    be there. the /x86_64 directory isn't there.
    Hi
    So what do you see from the output of;
    Code:
    mgr-create-bootstrap-repo -l
    --
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    openSUSE Leap 42.3|GNOME 3.20.2|4.4.120-45-default
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!


  7. #7

    Re: Trouble adding registering first client

    Quote Originally Posted by malcolmlewis View Post
    Hi
    So what do you see from the output of;
    Code:
    mgr-create-bootstrap-repo -l
    --
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    openSUSE Leap 42.3|GNOME 3.20.2|4.4.120-45-default
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

    1. SLE-11-SP1-x86_64
    2. SLE-11-SP2-x86_64
    3. SLE-11-SP3-x86_64
    4. SLES4SAP-11-SP2-x86_64
    5. SLES4SAP-11-SP3-x86_64
    6. SLES4SAP-12-SP1-x86_64
    7. SLES4SAP-12-SP3-x86_64


    I'm hoping the issue isn't the "4SAP" parts. Because I support SAP lol. When modifying the initial bootstrap file, does the filename make a huge difference? I made the changes according to the "getting started" guide. The funny thing is when I recreated the boostrap repo, I clearly see the packages I need being copied. Unless I am just doing the wrong one or something. When I run "mgr-create-bootstrap-repo -c SLES4SAP-12-SP1-x86_64" I saw the snippet below among other things.


    copy 'spacewalk-check-2.7.6.3-52.3.1.noarch'
    copy 'spacewalk-client-setup-2.7.6.3-52.3.1.noarch'
    copy 'spacewalk-client-tools-2.7.6.3-52.3.1.noarch'

  8. Re: Trouble adding registering first client

    Quote Originally Posted by clydeprice View Post
    1. SLE-11-SP1-x86_64
    2. SLE-11-SP2-x86_64
    3. SLE-11-SP3-x86_64
    4. SLES4SAP-11-SP2-x86_64
    5. SLES4SAP-11-SP3-x86_64
    6. SLES4SAP-12-SP1-x86_64
    7. SLES4SAP-12-SP3-x86_64


    I'm hoping the issue isn't the "4SAP" parts. Because I support SAP lol. When modifying the initial bootstrap file, does the filename make a huge difference? I made the changes according to the "getting started" guide. The funny thing is when I recreated the boostrap repo, I clearly see the packages I need being copied. Unless I am just doing the wrong one or something. When I run "mgr-create-bootstrap-repo -c SLES4SAP-12-SP1-x86_64" I saw the snippet below among other things.


    copy 'spacewalk-check-2.7.6.3-52.3.1.noarch'
    copy 'spacewalk-client-setup-2.7.6.3-52.3.1.noarch'
    copy 'spacewalk-client-tools-2.7.6.3-52.3.1.noarch'
    Hi
    So in /srv/www/htdocs/pub/repositories/sle/12/1/bootstrap/ there should be noarch, repodata and x86_64 directories?

    Your bootstrap activation key should be using SLES4SAP-12-SP1-x86_64 Pool, are the 'SLE Manager Tools' child channels selected? If you check under Software -> Channels -> SUSE there should be a the corresponding channel SLES4SAP-12-SP1-x86_64 Pool if you look at the child channels all ok and synced?
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  9. #9

    Re: Trouble adding registering first client

    Quote Originally Posted by malcolmlewis View Post
    Hi
    So in /srv/www/htdocs/pub/repositories/sle/12/1/bootstrap/ there should be noarch, repodata and x86_64 directories?

    Your bootstrap activation key should be using SLES4SAP-12-SP1-x86_64 Pool, are the 'SLE Manager Tools' child channels selected? If you check under Software -> Channels -> SUSE there should be a the corresponding channel SLES4SAP-12-SP1-x86_64 Pool if you look at the child channels all ok and synced?
    /srv/www/htdocs/pub/repositories/sle/12/1/bootstrap/repodata # ls -ltr
    total 16
    -rw-r--r-- 1 root root 123 Apr 11 09:27 ad0107628e9b6dd7a82553ba5cb447388e50900a-filelists.xml.gz
    -rw-r--r-- 1 root root 154 Apr 11 09:27 4a4fcd19720ecc2fc72c4e5b0e60a806c1387d10-primary.xml.gz
    -rw-r--r-- 1 root root 123 Apr 11 09:27 1eb13a25318339d9e8157f0bf80419c019fa5000-other.xml.gz
    -rw-r--r-- 1 root root 1262 Apr 11 09:27 repomd.xml


    And as far as the SLE Manager Tools, everything seems up to date. Last modified today. I see a lot of the spacewalk packages:

    spacewalk-check-2.1.16.4-2.9.noarch Check for Spacewalk actions SUSE LINUX Products GmbH
    spacewalk-client-setup-2.1.16.4-2.9.noarch Configure and register an Spacewalk client SUSE LINUX Products GmbH
    spacewalk-client-tools-2.1.16.4-2.9.noarch Support programs and libraries for Spacewalk SUSE LINUX Products GmbH
    zypp-plugin-spacewalk-0.9.8-3.7.x86_64 Client side Spacewalk integration for ZYpp SUSE LINUX Products GmbH

    And in the SLE-Manager-Tool-Updates x86_64 SAP-SP1 I see all the versions of the software. So I'm not sure what is going on there.

  10. Re: Trouble adding registering first client

    Quote Originally Posted by clydeprice View Post
    /srv/www/htdocs/pub/repositories/sle/12/1/bootstrap/repodata # ls -ltr
    total 16
    -rw-r--r-- 1 root root 123 Apr 11 09:27 ad0107628e9b6dd7a82553ba5cb447388e50900a-filelists.xml.gz
    -rw-r--r-- 1 root root 154 Apr 11 09:27 4a4fcd19720ecc2fc72c4e5b0e60a806c1387d10-primary.xml.gz
    -rw-r--r-- 1 root root 123 Apr 11 09:27 1eb13a25318339d9e8157f0bf80419c019fa5000-other.xml.gz
    -rw-r--r-- 1 root root 1262 Apr 11 09:27 repomd.xml


    And as far as the SLE Manager Tools, everything seems up to date. Last modified today. I see a lot of the spacewalk packages:

    spacewalk-check-2.1.16.4-2.9.noarch Check for Spacewalk actions SUSE LINUX Products GmbH
    spacewalk-client-setup-2.1.16.4-2.9.noarch Configure and register an Spacewalk client SUSE LINUX Products GmbH
    spacewalk-client-tools-2.1.16.4-2.9.noarch Support programs and libraries for Spacewalk SUSE LINUX Products GmbH
    zypp-plugin-spacewalk-0.9.8-3.7.x86_64 Client side Spacewalk integration for ZYpp SUSE LINUX Products GmbH

    And in the SLE-Manager-Tool-Updates x86_64 SAP-SP1 I see all the versions of the software. So I'm not sure what is going on there.
    Hi
    Is your SuMA host in the client hosts file? If not try adding as it may not be resolving back hence it can't find. So you also see the noarch and x86_64 directories in /srv/www/htdocs/pub/repositories/sle/12/1/bootstrap/ you have the repodata one....
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •