Hello,

I’m playing around with the Docker image functionality of SUSE Manager 3. The built process itself works perfect. What I cannot get to work is the "inspect"-part. According to https://www.suse.com/documentation/s...html#bp.images and https://wiki.microfocus.com/index.ph...Known_Pitfalls the packages python and python-xml have to be installed inside the image to get inspect to work. Well, IMHO my Dockerfile does exactly that. Here it is, very simplistic, just for testing:
Code:
FROM suse/sles12sp3:latest
ENV TZ='Europe/Berlin'
ARG repo
ARG cert
RUN rm /etc/localtime && ln -s /usr/share/zoneinfo/Europe/Berlin /etc/localtime && \
    echo "$cert" > /etc/pki/trust/anchors/RHN-ORG-TRUSTED-SSL-CERT.pem && \
    update-ca-certificates && \
    echo "$repo" > /etc/zypp/repos.d/susemanager:dockerbuild.repo && \
    zypper --gpg-auto-import-keys --non-interactive install python python-xml && \
    zypper clean && rm -rf /var/cache/zypp* && rm -f /etc/zypp/repos.d/susemanager:dockerbuild.repo
Running the container and executing "rpm –q python python-xml" returns both packages as installed.

Nevertheless, all I get is this grey question mark in the Updates column after a successful image built. Looking into the details of the image SUSE Manager shows me "Inspect is successful" as Inspect Status. Clicking on "Inspect is successful" gets me "Module function dockerng.sls_build executed (code 2)".

Except "code 2" everything looks fine for me.

We are running version 3.1.5 of SUSE Manager. Someone got a hint were to start trouble-shooting?

Thanks and best regards
Tim