I am trying to register my first server (SLES 11 SP1) to my newly installed SMT server (SLES 11 SP2). When I run the clientSetup4SMT.sh script (command ./clientSetup4SMT.sh https://wcs-mf-smt.xxx.com/center/regsvc) on 10.17.1.163 it returns with a message "Download failed. Abort.".

I checked the apache log files (on the SMT server) at /var/log/apache2 and see the following in the access_log:
10.17.1.163 - - [03/Jul/2012:10:48:08 -0500] "\x80\x89\x01\x03\x01" 400 306 "-" "-"

From error_log:
[Tue Jul 03 10:48:08 2012] [error] [client 10.17.1.163] invalid request-URI

The output from "rcsmt status" gives:
Using apache2 conf plugin /etc/apache2/conf.d/nu_server.conf
Using apache2 conf plugin /etc/apache2/conf.d/smt_mod_perl.conf
Using apache2 conf plugin /etc/apache2/conf.d/smt_support.conf
Not using apache2 vhosts plugin /etc/apache2/vhosts.d/vhost-ssl.conf (SMT not enabled)
Using cron plugin /etc/cron.d/novell.com-smt
Checking for httpd2: running
Checking for service MySQL: running
Checking for Cron: running


I checked file /etc/apache2/httpd.conf and think that the problem may be caused by section:
# forbid access to the entire filesystem by default
<Directory />
Options None
AllowOverride None
Order deny,allow
Deny from all
</Directory>


I wasn't getting this far until I used YaST to enable SSL in the apache server.

What do I need to change to resolve the "invalid request-URI" message?


Harley