I tried change my /home username so I switch to tty0 and change the username by usermod command but because some pid is active , can't modify user. So I kill those proccess with kill command. After this i reboot mu machine. Now for booting my machine, /home partition (XFS type) failed mount. So try fix that with
that was obviously a bad idea to simply kill that process. What kind of process was it? What exact command did you run to change the username?
You probably didn't log out of your session when switching to tty0, did you? I would assume that you corrupted the ownerships when changing the user with a mounted home directory (which is a very bad idea, but I guess you just learned that ). I hope you have a backup of your data.

I'm not too familiar with XFS, unfortunately. Does the system boot when you comment the home partition in /etc/fstab? Did you run xfs_repair from that stage? Have you tried to boot from iso into rescue mode and then try the repair command?
If you have enough space (or an external drive) you could try to copy the data from /dev/sda5 to another partition/drive with dd and see if you can mount that partition/drive or repair it. If that works you could copy the data back to its original place. Of course there is a chance you could copy corrupted data back to the partition. It's really tricky, maybe someone else has other suggestions.