Results 1 to 2 of 2

Thread: Some Problems With Connecting SRS-XB30 With Blueman Manager

  1. Question Some Problems With Connecting SRS-XB30 With Blueman Manager

    I have a problem connecting my Sony SRS-XB30 Bluetooth Speaker using Blueman Bluetooth Manager in OpenSUSE Leap 42.3 on my desktop computer. About a week ago it would connect fine without a problem. However, since then there was a few software updates through SUSE on-line and Bluedevil5 was replaced with Blueman Manager and it had problems re-pairing with the SRS-XB30 bluetooth speaker. The following is my basic information:

    blueman: Version 2.0.6-2.3.1
    BlueZ: Version 5.41-6.1
    Distribution: OpenSUSE Leap 42.3 64bit
    Desktop environment: Plasma KDE Version 5.8.7-2.1

    At first the problem was pairing the SRS-XB30 with the Blueman Manager because the SRS-XB30 expected to be paired with a PIN value of 0000, which the Blueman Manager never prompted for a PIN value directly on the Desktop screen but through the Plasma KDE Notifications. By the time I clicked on Notifications and then clicked on Enter Authority and the PIN prompt window finally appears the time has expired for me to enter the 0000 PIN value. However, when I finally got PIN value entered and the SRS-XB30 device paired with the bluetoothctl text command, there is still another problem with getting the SRS-XB30 device connected. The following indicates the problem:

    Code:
    [ThinkPad Compact Bluetooth Keyboard with TrackPoint]# pair B8:D5:0B:25:AA:4C
    Attempting to pair with B8:D5:0B:25:AA:4C
    [CHG] Device B8:D5:0B:25:AA:4C Paired: yes
    Pairing successful
    [CHG] Device B8:D5:0B:25:AA:4C Connected: yes
    [CHG] Device B8:D5:0B:25:AA:4C Connected: no
    [ThinkPad Compact Bluetooth Keyboard with TrackPoint]# list-attributes B8:D5:0B:25:AA:4C
    [ThinkPad Compact Bluetooth Keyboard with TrackPoint]# info B8:D5:0B:25:AA:4C
    Device B8:D5:0B:25:AA:4C
            Name: SRS-XB30
            Alias: SRS-XB30
            Class: 0x240414
            Icon: audio-card
            Paired: yes
            Trusted: yes
            Blocked: no
            Connected: no
            LegacyPairing: yes
    [ThinkPad Compact Bluetooth Keyboard with TrackPoint]# connect B8:D5:0B:25:AA:4C
    Attempting to connect to B8:D5:0B:25:AA:4C
    [CHG] Device B8:D5:0B:25:AA:4C Connected: yes
    [CHG] Device B8:D5:0B:25:AA:4C Modalias: bluetooth:v0039p1582d2203
    [CHG] Device B8:D5:0B:25:AA:4C UUIDs: 00000000-deca-fade-deca-deafdecacaff
    [CHG] Device B8:D5:0B:25:AA:4C UUIDs: 00001108-0000-1000-8000-00805f9b34fb
    [CHG] Device B8:D5:0B:25:AA:4C UUIDs: 0000110b-0000-1000-8000-00805f9b34fb
    [CHG] Device B8:D5:0B:25:AA:4C UUIDs: 0000110c-0000-1000-8000-00805f9b34fb
    [CHG] Device B8:D5:0B:25:AA:4C UUIDs: 0000110e-0000-1000-8000-00805f9b34fb
    [CHG] Device B8:D5:0B:25:AA:4C UUIDs: 0000111e-0000-1000-8000-00805f9b34fb
    [CHG] Device B8:D5:0B:25:AA:4C UUIDs: 00001200-0000-1000-8000-00805f9b34fb
    Failed to connect: org.bluez.Error.Failed
    [CHG] Device B8:D5:0B:25:AA:4C Connected: no
    [ThinkPad Compact Bluetooth Keyboard with TrackPoint]# connect B8:D5:0B:25:AA:4C
    Attempting to connect to B8:D5:0B:25:AA:4C
    Failed to connect: org.bluez.Error.Failed
    [ThinkPad Compact Bluetooth Keyboard with TrackPoint]#
    However, when I go back using the Blueman Manager GUI, I now see the following:

    [IMG]Blueman-Manager-6.0.2-SRS-XB30-04.png[/IMG]

    When I click on the "More" button, the following information is shown:

    [IMG]Blueman-Manager-6.0.2-SRS-XB30-05.png[/IMG]

    From what I understand from this error message displayed, it looks like the DBus support for the blueman.bluez Bluetooth Stack is missing the protocol for the Sony SRS-XB30 loudspeaker device, which is odd because the SRS-XB30 device was working fine prior to the OpenSUSE Leap 42.3 update on-line from SUSE. Can anyone correct this problem with the DBus data base?

    Thank you,

    David A. Smith

  2. Re: Some Problems With Connecting SRS-XB30 With Blueman Mana

    Hi and welcome to the Forum
    Unfortunately these forusm are for SUSE Linux Enterprise, not openSUSE, you need to head over to https://forums.opensuse.org/forum.php same user name and login
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •