More info:

After waking from sleep, the modem was off. In order to get it started again I had to do the following

1. Execute the 'ip link set wwan0 up' command to turn on the interface.
2. Execute the 'mbim-network /dev/cdc-wdm0 start' command.
3. Toggle the Mobile Broadband setting to be on withing Gnome's Settings application under the Network section.

After performing these three steps on system wake, I can use the modem. I'm wondering if perhaps the modem is being disabled on sleep and then not woken up. I do have the tlp and tlp-sleep services installed and active. Will report back if I find out more.