Results 1 to 4 of 4

Thread: Enable xclock / RDP on google cloud virtual machin

Hybrid View

  1. #1

    Question Enable xclock / RDP on google cloud virtual machin

    Hi Team,

    I installed SLES 12 SP4 for SAP Application on Google cloud. It doesn't have xclock and not able to take RDP session of it.
    For installation of Oracle, we need to set DISPLAY variable and need to run "RUNINSTALLER" its failing because of DISPLAY variable.

    Let me know which packages needs to be installed to run GUI application on SLES 12

    Thanks
    Raj

  2. #2

    Re: Enable xclock / RDP on google cloud virtual machin

    Quote Originally Posted by raj4721 View Post
    Hi Team,

    I installed SLES 12 SP4 for SAP Application on Google cloud. It doesn't have xclock and not able to take RDP session of it.
    For installation of Oracle, we need to set DISPLAY variable and need to run "RUNINSTALLER" its failing because of DISPLAY variable.

    Let me know which packages needs to be installed to run GUI application on SLES 12

    Thanks
    Raj
    Getting below error while running commands,

    zypper install xrdp
    No reporsitories defined. Operating only with installed resolvables. Nothing can be installed.

  3. #3

    Re: Enable xclock / RDP on google cloud virtual machin

    Quote Originally Posted by raj4721 View Post
    I installed SLES 12 SP4 for SAP Application on Google cloud. It doesn't have xclock and not able to take RDP session of it.
    For installation of Oracle, we need to set DISPLAY variable and need to run "RUNINSTALLER" its failing because of DISPLAY variable.

    Let me know which packages needs to be installed to run GUI application on SLES 12
    Are you using SAP applications? Since you've referenced SLES for SAP Applications and posted in this forum I'm guessing you might be (planning to). Are you also then hoping to install Oracle applications on the same server?

    HTH.
    Simon
    SUSE Knowledge Partner
    ------------------------------------------------------------------------
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below. Thanks.

  4. #4

    Re: Enable xclock / RDP on google cloud virtual machin

    issue fixed by assigning static public (external) ip to GCP VM. Once VM established connection to internet it was able to download required packages.

    Steps to follow to enable xclock on Google cloud platform - Compute Engine

    1. Assign public ip
    2. Login using root (sudo su – root)
    3. Run below commands,
    a. zypper install -t pattern gnome-basic
    b. zypper install xrdp
    c. https://answers.sap.com/questions/12...rise-serv.html
    4. Install putty - https://www.putty.org/
    5. Enable X11 in putty. (Putty main login page, before login to system)
    6. Install Xming - https://sourceforge.net/projects/xming/
    7. Double click “Xming”, that’s it
    8. Open putty,
    a. login with root
    b. export DISPLAY=10.142.0.2:0
    c. xclock
    9. if any issues with host/protocol
    a. run command xhost + (This gives access to all hosts)
    b. export DISPLAY=:0
    c. Manually add entry to “C:\Program Files (x86)\Xming\X0.hosts”
    d. Restart Xming and putty

    Hope this help someone looking for an similar issue.

    Cheers,
    Raj

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •