Hi Experts,
I am new to this SLSE. I am using SLES 11 sp4.
I have downloaded SAPCAR latest and also downlaoded SWPMxxxxxx.sar file from SAP support portal.
I have created VM and have installed SLSE 11 sp4 in Windows 64 box using VMplayer 15.
As per the SAP instllation guide, I have copied to temporary directory and tried unzip using this SAPCAR but it is giving me error like below.

Steps I followed is:
1. Logged in as root
2. renamed this file as per the sap guide: mv SAPCAR.EXE SAPCAR
SAPECC:/saptmp # SAPCAR -xvf SWPM10SP27.SAR
bash: ./sapcar: cannot execute binary file

SAPECC:/saptmp # ls -lrt
total 527340
-rwxr-xr-x 1 root root 4574560 Oct 13 02:30 sapcar
-rwxr-xr-x 1 root root 534877034 Oct 13 03:51 SWPM10SP27.SAR

I am getting this error and I have tried to execute with extension .exe and without extension, in both the cases i am getting the same issue.
bash: ./sapcar: cannot execute binary file

I have checked my SAPCAR I have downloaded is linux belongs to X86 64 bit.
Something is missing in my OS setup since I have created VM?
Experts can help me how to resolve this.