Quote Originally Posted by pri14bal View Post
Hi Everyone,

I have configured a pacemaker stonith fencing agent using sbd (Cluster is on SLES 12 SP3).
The watchdog used is softdog.

The crm property is set as stonith-action="poweroff"

But still each time there is an action triggered (for e.g. in case of interface going down) for sbd, it reboots the node instead of shutdown of the node.
The poweroff option is not working as expected.

Is there any other option that needs to be set or any other parameter that would make this work!

Thanks ahead!
Can you provide the stonith resource configuration?
Code:
crm configure show <sbd_resource>
You can view the meta even for stonith devices via(note, take the device type from cluster configuration and replace below):
Code:
crm ra  classes
crm ra  list stonith
crm ra info stonith:<type-of-stonith-device>
Most probably you haven't defined what the SBD should do and it takes 'reboot' as default.