Results 1 to 7 of 7

Thread: Could not resolve the DNS issue

Hybrid View

  1. Could not resolve the DNS issue

    Hi Experts,

    I am new to SUSE LInux and I am trying to install SAP system.
    I am facing the below issue while starting installation.

    Problem with the DNS configuration: could not determine the DNS domain of host localhost
    ================================================== =
    Below are config details: If i do nslookup to local host it is resolving.

    localhost:~ # nslookup localhost
    Server: 62.241.198.246
    Address: 62.241.198.246#53

    Non-authoritative answer:
    Name: localhost
    Address: 127.0.0.1
    ================================================== ==========
    Under network settings, hostname is mentioned localhost and domain mentioned as suse by default.
    iN this case it is not resolving.

    localhost:~/saptemp # nslookup localhost.suse


    Server: 62.241.198.246

    Address: 62.241.198.246#53

    **
    server can't find localhost.suse: NXDOMAIN

    ======================================
    more /etc/resolv.conf
    ### /etc/resolv.conf


    search pp.htv.fi

    nameserver 62.241.198.246

    nameserver 62.241.198.245

    What could be the issue in this case?
    I am not linux admin, if some can help on this would be great.

    Thanks in advance.

  2. Re: Could not resolve the DNS issue

    Hi
    You should be using a FQDN (Fully Qualified Domain Name) the .suse is just for local use and temporarily until you set your hostname and domain. This is normally done via YaST network settings against the interface(s) in use.

    I normally set mine also in the /etc/hosts file against 127.0.0.2

    For example;

    Code:
    hostname -f
    
    oscar.homelinux.org
    
    
    dig oscar.homelinux.org @gekkota-dns1
    
    ; <<>> DiG 9.11.2 <<>> oscar.homelinux.org @gekkota-dns1
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 7080
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 1
    
    ;; OPT PSEUDOSECTION:
    ; EDNS: version: 0, flags:; udp: 4096
    ;; QUESTION SECTION:
    ;oscar.homelinux.org.		IN	A
    
    ;; ANSWER SECTION:
    oscar.homelinux.org.	2	IN	A	192.168.10.80
    
    ;; Query time: 5 msec
    ;; SERVER: 192.168.10.3#53(192.168.10.3)
    ;; WHEN: Fri Oct 18 16:25:20 CDT 2019
    ;; MSG SIZE  rcvd: 64
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  3. Re: Could not resolve the DNS issue

    Hi Malcolmlewis,

    Thanks for your response.
    Below is current status. Still i am unable to resolve DNS by giving this way: nslookup sapecc
    Something I am missing which i am unable to trace it out.
    Seeking more help on this.

    apecc:/etc # dig sapecc.chandra.com


    ; <<>> DiG 9.9.6-P1 <<>> sapecc.chandra.com

    ;; global options: +cmd

    ;; Got answer:

    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 25110

    ;; flags: qr rd ra
    ; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 1

    ;; OPT PSEUDOSECTION:

    ; EDNS: version: 0, flags:
    ; udp: 4096

    ;; QUESTION SECTION:

    ;sapecc.chandra.com. IN A


    ;; ANSWER SECTION:
    sapecc.chandra.com. 300 IN A 64.99.80.121


    ;; Query time: 272 msec

    ;; SERVER: 62.241.198.246#53(62.241.198.246)

    ;; WHEN: Sat Oct 19 10:14:24 EDT 2019

    ;; MSG SIZE rcvd: 63

    ==========================

    sapecc:/etc # nslookup sapecc.chandra.com

    Server: 62.241.198.246

    Address: 62.241.198.246
    #53

    Non-authoritative answer:

    Name: sapecc.chandra.com

    Address: 64.99.80.121



    ============================

    Host file:


    # IP-Address Full-Qualified-Hostname Short-Hostname

    #


    127.0.0.1 sapecc.chandra.com sapecc
    #127.0.0.1 localhost



    # special IPv6 addresses

    ::1 localhost ipv6-localhost ipv6-loopback


    fe00::0 ipv6-localnet


    ff00::0 ipv6-mcastprefix

    ff02::1 ipv6-allnodes

    ff02::2 ipv6-allrouters

    ff02::3 ipv6-allhosts

  4. Re: Could not resolve the DNS issue

    Hi
    The 127.0.0.1 and localhost are important, move your hostname and fqdn to 127.0.0.2 instead.

    It all resolves here, so it must be your DNS servers that are the issue....

    Code:
    nslookup sapecc.chandra.com
    
    Server:		192.168.10.3
    Address:	192.168.10.3#53
    
    Non-authoritative answer:
    Name:	sapecc.chandra.com
    Address: 64.99.80.121
    
    dig sapecc.chandra.com @8.8.8.8
    
    ; <<>> DiG 9.11.2 <<>> sapecc.chandra.com @8.8.8.8
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 43799
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 1
    
    ;; OPT PSEUDOSECTION:
    ; EDNS: version: 0, flags:; udp: 512
    ;; QUESTION SECTION:
    ;sapecc.chandra.com.		IN	A
    
    ;; ANSWER SECTION:
    sapecc.chandra.com.	299	IN	A	64.99.80.121
    
    ;; Query time: 114 msec
    ;; SERVER: 8.8.8.8#53(8.8.8.8)
    ;; WHEN: Sat Oct 19 11:10:16 CDT 2019
    ;; MSG SIZE  rcvd: 63
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  5. Re: Could not resolve the DNS issue

    By the way, SLES11 is in last phase of support (even for SAP-based one) and it is highly recommended to switch either to SLES12SP4 or even ro SLES15SP1.

  6. Re: Could not resolve the DNS issue

    Quote Originally Posted by strahil-nikolov-dxc View Post
    By the way, SLES11 is in last phase of support (even for SAP-based one) and it is highly recommended to switch either to SLES12SP4 or even ro SLES15SP1.
    Hi
    LTSS goes to 31 Mar 2022 for SUSE Linux Enterprise Server for SAP Applications 11 SP4. It's already out of general support....
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  7. Re: Could not resolve the DNS issue

    Hi Malcolm,

    Thanks for your help and pointed to help on the issue in the right direction.
    Finally I am able to solve with your help.
    It is the problem in DNS setting where currently it was to Auto mode to obtain IP automatically.
    This was the issue which was causing this. I have changed to static by assigning IP.
    Thanks for your help once again

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •