Hi all,

I am sure this post will be pretty easy for most of you, but I am a beginner and I can't seem to find the fix.

I am setting up a couple of NFSv4 shares, here it is the environment:

In my NFS server (S2), I open the NFS Server module from Yast, select to start the server, open port in firewall, I check the "Enable NFSv4" option, I enter my domain name and hit next.

There, add a Directory, I browse my /nfs_exports dir, host will card=*, and in this order the options= fsid=0,crossmnt,rw,root_squash,sync,no_subtree_che ck.

Then, I also export> /nfs_exports/home, host=*, options=rw,root_squash,sync,no_subtree_check,bind=/export/home. Then I click on finish and everything looks good.

/etc/exports:

/nfs_exports *(fsid=0,crossmnt,rw,root_squash,sync,no_subtree_c heck)
/nfs_exports/home *(rw,root_squash,sync,no_subtree_check,bind=/export/home)


server2:~/Desktop # showmount -e localhost
Export list for localhost:
/nfs_exports *
/nfs_exports/home *

Line from mount command:

/export/home on /nfs_exports/home type none (rw,bind,nfsexp)


Everything looks good to me, so from there I jump to my NFS client (S1).

server1:~ # grep -i nfs4 /etc/sysconfig/nfs
NFS4_SUPPORT="yes"

I open the NFS client module, go to the NFS Settings tab, enable NFSv4 and enter my domain name (NFSv4 Domain), open por in firewall. Then, back in the NFS shares tab, add, NFS server Host=server2, remote directory=/nfs_exports/home, mount point=/imports/nfs/home, I check the NFSv4 share option, options=defaults,soft and then hit ok. Then I hit ok and guess what: "Error. Unable to mount the NFS entries from /etc/fstab."

If I uncheck the nfsv4 share option from the nfs client module, it will work just fine, no errors at all:

/etc/fstab:
server2:/nfs_exports/home /import/nfs/home nfs defaults,soft 0 0

If I try to mount the NFS4 share manually, this is what I get:

server1:~ # mount -t nfs4 s2:/nfs_exports/home /import/nfs/home/
mount.nfs4: mounting s2:/nfs_exports/home failed, reason given by server:
No such file or directory

Which is completely weird, I just don't get it.

If I manually edit /etc/fstab and add the line:

server2:/nfs_exports/home /import/nfs/home nfs4 defaults,soft 0 0

I get the same mount error as before:

server1:~ # mount -a
mount.nfs4: mounting server2:/nfs_exports/home failed, reason given by server:
No such file or directory

Then, just for testing, I tried mounting the pseudo root directory manually, and this attempt was succesfull:

server1:~ # mount -t nfs4 s2:/ /import/nfs/home/

server1:~ # mount
s2:/ on /import/nfs/home type nfs4 (rw,clientaddr=192.168.1.2,addr=192.168.1.3)

If I check the /import/nfs/home, the pseudo file system is all there, I can access the /nfs_export/home dir:

server1:~ # ls /import/nfs/home/
home

It will work fine also if I add the following line to /etc/fstab:

server2:/ /import/nfs/home nfs4 defaults,soft 0 0

So in summary, I can only mount server2:/. I can not mount say server2:/nfs_exports/home separately.

However, what I want to do is that, mount /nfs_exports/home to /imports/nfs/home, and a future share /nfs_exports/projects to /imports/nfs/projects, mounting the whole pseudo file system to a single directory will not work for me.

Do you guys know if this is possible? If it is, would you help me? I tried to include all relevant information, if you'd like me to send you anything else just let me know.

Warm Regards,

Diego