I'm trying to build an app (from the intel AMT SDK) on Suse Enterprise Edition. (supported platform)

When I execute the make command I get the following error :

~/Projects/intelamt/LinuxAMT/Intel_AMT/Samples/Redirection/RedirectionSample> make
g++ imrcli.cpp -I../../../Include -L../../../Lib -L/usr/local/ssl/lib64 -limrsdkSuSE11 -luuid -lpthread -lssl -lcrypto -Wno-write-strings -o imrcli
/usr/lib/gcc/i586-suse-linux/4.3/../../../../i586-suse-linux/bin/ld: cannot find -luuid
collect2: ld returned 1 exit status
make: *** [imrcli] Error 1


I tried installing libuuid-devel (had the same issue on Ubuntu and Centos, and that package fixed it), however Suse doesn't seem to find it.

~/Projects/intelamt/LinuxAMT/Intel_AMT/Samples/Redirection/RedirectionSample> sudo zypper install libuuid-devel
Refreshing service 'nu_novell_com'.
Loading repository data...
Reading installed packages...
'libuuid-devel' not found in package names. Trying capabilities.
No provider of 'libuuid-devel' found.
Resolving package dependencies...

Any ideas why it doesn't find it and who I can get it to install ?