I'm attempting to install SLES 11 SP2 into Citrix XenServer 6.1.0 but the
first boot after the initial install is hanging. The following is the last
thing on the console prior to the hang:

[ 4.095474] usbcore: registered new interface driver usbhid
[ 4.119024] usbhid: v2.6:USB HID core driver

Unlike SP2, I can successfully install SP1 into the same XenServer. Watching
SP1 boot, the following would be the next message to appear on the console:

[ 11.160724] udevd version 128 started

I believe this implies that there's an issue when first attempting to access
the device with the root image (problem with the device itself or with the
udev rules?).

Here's the default kernel and initrd lines used by grub for the SP2 boot (I
found these by hitting ESC at the initial grub boot menu):

kernel (hd0,1)/boot/vmlinuz-3.0.34-0.7-default root=/dev/sda2 resume=/dev/hda1 splash=silent showopts vga=0x314
initrd (hd0,1)/boot/initrd-3.0.34-0.7-default

I thought it was odd that root refers to sda2 and that resume refers to
hda1 but I've tried just about every possible permutation and nothing
seems to work. In fact, if I set root=/dev/foobar I get the same hanging
behavior and no additional error messages.

In XenCenter, the "Device Path" for my virtual disk lists "/dev/hda" and
it's "Device Position" in the properties is set to "0". These are identical
for both the failed SP2 system and the successfully booting SP1 system.

As an additional test to try and narrow things down I copied my SP2 kernel
and initrd into my SP1 virtual machine and booted it. This causes the SP1
boot to hang at the exact same place as the SP2 boot but this time I get an
additional console message:

....................Could not find /dev/sda2.

This seems to again point at some sort of issue when first accessing the
root image for the first time.

Note that XenServer does not currently support SP2 and I'm not using the
SP1 Template that they provide. I'm instead using the "Other install
media" option when creating the VM.

Any help would be much appreciated.

Thanks!