Hello
I have noticed something "strange" happens when using the parameter dom0_mem.

I use a SLES11 SP2 with kernel 3.0.13-0.27-xen x86_64 where grub parameters are 'kernel /xen.gz vga=mode-0x317 dom0_mem=1024M'
The computer has 4GB RAM, which runs one DomU 2GB RAM (backuppc)

When I run the command 'du' or 'fsck' in the dom0, these commands behave erroneous.

the command 'du' run on a usb external hard disk error tells me:

du: cannot access `/mnt/copia/.....': Input/output error


This is done randomly, 1st see indicates an error and does not indicate the 2nd mistake. This makes it usb disk or a SATA drive connected to the motherboard.



After fsck indicates that the filesystem is inconsistent, indicating errors

Inode 2154525 has illegal block(s). Clear<y>?
Inode 1393089 has EXTENTS_FL flag set on filesystem without extents support.
Inode 8460056 has a extra size (14394) which is invalid Fix<y>? ye
Inode 8460057 has imagic flag set. Clear<y>? yes
Inode 8460059 has a extra size (14394) which is invalid Fix<y>? yes
Inode 8460049 has compression flag set on filesystem without compression support. Clear<y>? yes
Inode 8460049 has INDEX_FL flag set but is not a directory.
Clear HTree index<y>? yes
Inode 8460049, i_size is 10405922140023030687, should be 0. Fix<y>? yes
(errors are several different times)

Reaching the dom0_mem conclucion that produces much change took me hard, reinstallation of OS and many twists and turns.


Any suggestions you can produce?
There is a hardware error, because by using the same hardware and run the fsck produces no errors


As always thanks for reading this far down .. and excuse the English,