Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: mount cifs does not work after SP2 upgrade

Hybrid View

  1. mount cifs does not work after SP2 upgrade

    Hi Forum,

    this mount was working on SLES11 SP1
    mount //server/share /mnt/share -o username=user,password=password,uid=1000,gid=1000, workgroup=WG,file_mode=0330,dir_mode=0770

    after SP2 upgrade:
    mount error(2): No such file or directory
    Refer to the mount.cifs(8) manual page ...

    ?????

    Thank you for your support
    MiC

  2. Re: mount cifs does not work after SP2 upgrade

    mount //server/share/FOLDER ... does not work!

    mount //server/share .... OK

  3. #3

    Re: mount cifs does not work after SP2 upgrade

    On 07/08/2013 10:14, netzpks wrote:

    > this mount was working on SLES11 SP1
    > mount //server/share /mnt/share -o
    > username=user,password=password,uid=1000,gid=1000, workgroup=WG,file_mode=0330,dir_mode=0770
    >
    > after SP2 upgrade:
    > mount error(2): No such file or directory
    > Refer to the mount.cifs(8) manual page ...
    >
    > ?????


    Do SLES11 SP1 & SP2 refer to the server (where you're trying to mount
    from) or the client (mount to)?

    I think you mean client and if so, what OS is server running?

    Your follow-up message also says //server/share works but
    //server/share/FOLDER doesn't - since that conflicts with the above
    report was that the case with SP1?

    HTH.
    --
    Simon
    SUSE Knowledge Partner

    ------------------------------------------------------------------------
    Do you work with SUSE technologies at a university, college or school?
    If so, your campus could benefit from joining the Technology Transfer
    Partner (TTP) program. See novell.com/ttp for more details.
    ------------------------------------------------------------------------

  4. Re: mount cifs does not work after SP2 upgrade

    Hi Simon,
    thank you, for your help.

    I try to describe:
    our SLES11 SP1 Server connects to the network share //fqdn/sharename/foldername (like above described)
    yesterday i upgraded our SLES11 SP1 Server to SLES11 SP2. Everything went fine.
    Only the mount cifs behavior has changed.
    Now it is possible to connect to //fqdn/share but not to //fqdn/share/foldername

    if i try to connect to //fqdn/sharename/foldername i get the error
    mount error(2): No such file or directory
    Refer to the mount.cifs(8) manual page ...

  5. Re: mount cifs does not work after SP2 upgrade

    Hi netzpks,

    this may have been a regression in the CIFS code (client side). I don't have a test system at hand atm, but will check once I have access to my testbed again.

    Can you verify the versions of both cifs modules ("modprobe cifs" on SP1 and SP2)?

    Regards,
    Jens

  6. Re: mount cifs does not work after SP2 upgrade

    Quote Originally Posted by jmozdzen View Post
    Hi netzpks,

    this may have been a regression in the CIFS code (client side). I don't have a test system at hand atm, but will check once I have access to my testbed again.

    Can you verify the versions of both cifs modules ("modprobe cifs" on SP1 and SP2)?

    Regards,
    Jens
    Hi Jens,

    SP1: no result for "modprobe cifs"
    SP2: -"-

    SP1: modprobe -l | grep cifs ==> /lib/modules/2.6.32.59-0.7-default/kernel/fs/cifs/cifs.ko
    SP2: modprobe -l | grep cifs ==> /lib/modules/3.0.80-0.7-default/kernel/fs/cifs/cifs.ko

    SP1 & SP2:
    installed: cifs-mount | Version 3.4.3-1.42.1

  7. Re: mount cifs does not work after SP2 upgrade

    Hi netzpks,

    > "modprobe cifs"

    my fault & my apology - make that "modinfo cifs"

    Sorry,
    Jens

  8. Re: mount cifs does not work after SP2 upgrade

    Hi Jens,

    SP2:

    filename: /lib/modules/3.0.80-0.7-default/kernel/fs/cifs/cifs.ko
    version: 1.74
    description: VFS to access servers complying with the SNIA CIFS Specification e.g. Samba and Windows
    license: GPL
    author: Steve French <sfrench@us.ibm.com>
    srcversion: 21C0F989F2614B6537EB320
    depends:
    supported: external
    vermagic: 3.0.80-0.7-default SMP mod_unload modversions
    parm: CIFSMaxBufSize:Network buffer size (not including header). Default: 16384 Range: 8192 to 130048 (int)
    parm: cifs_min_rcv:Network buffers in pool. Default: 4 Range: 1 to 64 (int)
    parm: cifs_min_small:Small network buffers in pool. Default: 30 Range: 2 to 256 (int)
    parm: cifs_max_pending:Simultaneous requests to server. Default: 50 Range: 2 to 256 (int)
    parm: echo_retries:Number of echo attempts before giving up and reconnecting server. Default: 5. 0 means never reconnect. (ushort)



    SP1:

    filename: /lib/modules/2.6.32.59-0.7-default/kernel/fs/cifs/cifs.ko
    version: 1.61
    description: VFS to access servers complying with the SNIA CIFS Specification e.g. Samba and Windows
    license: GPL
    author: Steve French <sfrench@us.ibm.com>
    srcversion: 540058F0F094AF79A1047A8
    depends:
    supported: external
    vermagic: 2.6.32.59-0.7-default SMP mod_unload modversions
    parm: CIFSMaxBufSize:Network buffer size (not including header). Default: 16384 Range: 8192 to 130048 (int)
    parm: cifs_min_rcv:Network buffers in pool. Default: 4 Range: 1 to 64 (int)
    parm: cifs_min_small:Small network buffers in pool. Default: 30 Range: 2 to 256 (int)
    parm: cifs_max_pending:Simultaneous requests to server. Default: 50 Range: 2 to 256 (int)



    Many thanks for your help!

  9. Re: mount cifs does not work after SP2 upgrade

    Hi netzpks,

    my apologies for the delay, it took me a while to get access to the proper systems. I now was able to test it... and it works for me both for SP1 and SP2.

    Code:
    sp1-host # cat /etc/SuSE-release 
    SUSE Linux Enterprise Server 11 (x86_64)
    VERSION = 11
    PATCHLEVEL = 1
    sp1-host # modinfo cifs
    filename:       /lib/modules/2.6.32.36-0.5-xen/kernel/fs/cifs/cifs.ko
    version:        1.61
    description:    VFS to access servers complying with the SNIA CIFS Specification e.g. Samba and Windows
    license:        GPL
    author:         Steve French <sfrench@us.ibm.com>
    srcversion:     9DFE16BF7490949C21577D4
    depends:        
    supported:      external
    vermagic:       2.6.32.36-0.5-xen SMP mod_unload modversions Xen 
    parm:           CIFSMaxBufSize:Network buffer size (not including header). Default: 16384 Range: 8192 to 130048 (int)
    parm:           cifs_min_rcv:Network buffers in pool. Default: 4 Range: 1 to 64 (int)
    parm:           cifs_min_small:Small network buffers in pool. Default: 30 Range: 2 to 256 (int)
    parm:           cifs_max_pending:Simultaneous requests to server. Default: 50 Range: 2 to 256 (int)
    sp1-host # mount -ousername=myuser //mysambaserver/share /mnt
    Password: 
    sp1-host # l /mnt
    [... content of root dir of share ...]
    sp1-host # umount /mnt
    sp1-host # mount -ousername=myuser //mysambaserver/share/subdir /mnt
    Password: 
    sp1-host # l /mnt
    [... content of subdir of share ...]
    and on SP2

    Code:
    sp2-host # cat /etc/SuSE-release
    SUSE Linux Enterprise Server 11 (x86_64)
    VERSION = 11
    PATCHLEVEL = 2
    sp2-host:~ # modinfo cifs
    filename:       /lib/modules/3.0.80-0.7-xen/kernel/fs/cifs/cifs.ko
    version:        1.74
    description:    VFS to access servers complying with the SNIA CIFS Specification e.g. Samba and Windows
    license:        GPL
    author:         Steve French <sfrench@us.ibm.com>
    srcversion:     21C0F989F2614B6537EB320
    depends:
    supported:      external
    vermagic:       3.0.80-0.7-xen SMP mod_unload modversions Xen
    parm:           CIFSMaxBufSize:Network buffer size (not including header). Default: 16384 Range: 8192 to 130048 (int)
    parm:           cifs_min_rcv:Network buffers in pool. Default: 4 Range: 1 to 64 (int)
    parm:           cifs_min_small:Small network buffers in pool. Default: 30 Range: 2 to 256 (int)
    parm:           cifs_max_pending:Simultaneous requests to server. Default: 50 Range: 2 to 256 (int)
    parm:           echo_retries:Number of echo attempts before giving up and reconnecting server. Default: 5. 0 means never reconnect. (ushort)
    sp2-host # mount -ousername=myuser //mysambaserver/share /mnt
    Password: 
    sp2-host # l /mnt
    [... content of root dir of share ...]
    sp2-host # umount /mnt
    sp2-host # mount -ousername=myuser //mysambaserver/share/subdir /mnt
    Password: 
    sp2-host # l /mnt
    [... content of subdir of share ...]
    What OS / server software is the server running, the one your SLES server connects to? Unfortunately, I cannot test against MS Windows, I have only Linux servers around...

    Regards,
    Jens

  10. Re: mount cifs does not work after SP2 upgrade

    Hi Jens!

    Thank you for your efforts!
    SLES connects to MS Windows.

    Our Developer has adapted the python program. Now: "mount //server/share" and from there it is possible to change to the wanted folders.

    Many thanks
    netzpks

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •