We have a very odd issue we are trying to solve. We have several FTP servers that serve up FTP, Samba and NFS. Some run SLES 10 SP1, the later ones run SLES 11 SP1. The 10GbE NICs installed in the machines are identical. We need to move FTP clients to the servers running SLES 11 SP1.

During this we noticed that if you MD5 a file that has been transferred via FTP to a Windows 32 bit client from a SLES 11 SP1 server it does not come back as expected. The file has become corrupted. The same process from a SLES 10 SP1 server yields the correct MD5.

If you do the same transfer using Samba the MD5s are correct from both servers. We have tried building pure-ftp from source and running the same versions on both SLES 10 and SLES 11. SLES 11 still has the corruption issue.

To add confusion, performing an FTP transfer from a linux client or Windows 64 bit client, the FTP transfers are fine from both the SLES 10 or SLES 11 servers...

We have tried upgrading the network drivers on the windows 32 bit clients and the Linux servers, but made no difference. Also tried disabling the TCP offload checksum on the windows 32 bit clients - again, no change.

Any ideas would be much appreciated!