We have SLES 11.1 installed on Power on an LPAR and using Virtual CD rom
devices from the VIO. the problem of "mount: no medium found on
/dev/sr0" just occured over time and reboots would not fix the problem.
New Virtual CD devices would work for a time and then exhibit the same
problem.

I have found a workaround.. for some reason the system thinks the drive
tray is ejected and "eject -t /dev/sr0" will fix the problem. I can not
reproduce the problem using the eject command (just fix it).

It would be nice to figure out what is causing this to happen (I am
suspecting haldaemon, but I need time to test as this happens over a
period of time .. not instantly)

---------------------------------------------------

test005:~ # mount /dev/sr0 /mnt
mount: /dev/sr0: unknown device

test005:~ # mount -t iso9660 -o ro /dev/sr0 /mnt
mount: no medium found on /dev/sr0
test005:~ # mount -t iso9660 -o ro /dev/sr1 /mnt
mount: no medium found on /dev/sr1

test005:~ # mount -t auto -r /dev/sr1 /mnt
mount: /dev/sr1: unknown device

scsi 0:0:3:0: CD-ROM AIX VOPTA PQ: 0
ANSI: 4
sr0: scsi-1 drive
sr 0:0:3:0: Attached scsi CD-ROM sr0
sr 0:0:3:0: Attached scsi generic sg2 type 5
scsi 0:0:4:0: CD-ROM AIX VOPTA PQ: 0
ANSI: 4
sr1: scsi-1 drive
sr 0:0:4:0: Attached scsi CD-ROM sr1
sr 0:0:4:0: Attached scsi generic sg3 type 5


test005:~ # lsmod | grep -i cd
ide_cd_mod 39056 0
cdrom 50908 2 ide_cd_mod,sr_mod
test005:~ # modinfo cdrom
filename:
/lib/modules/2.6.32.12-0.7-ppc64/kernel/drivers/cdrom/cdrom.ko
license: GPL
srcversion: 62C2EBD8A5E64C4EF2C0076
depends:
supported: yes
vermagic: 2.6.32.12-0.7-ppc64 SMP mod_unload modversions
parm: debug:bool
parm: autoclose:bool
parm: autoeject:bool
parm: lockdoor:bool
parm: check_media_type:bool
parm: mrw_format_restart:bool


test005:~ # cdinfo /dev/sr0
CD Info 1.1 | (c) 1996-98 Gerd Knorr & Heiko Ei▀feldt
cdinfo: /dev/sr0: No medium found
test005:~ # cdinfo /dev/sr1
CD Info 1.1 | (c) 1996-98 Gerd Knorr & Heiko Ei▀feldt
cdinfo: /dev/sr1: No medium found


**********************************************
**********************************************
THE FIX
**********************************************
**********************************************

test005:~ # eject -t /dev/sr0
test005:~ # cdinfo /dev/sr0
CD Info 1.1 | (c) 1996-98 Gerd Knorr & Heiko Ei▀feldt
__________________________________
track list (1 - 1)
nr: msf lba ctrl adr type
1: 00:02:00 (000000) 0x4 0x1 data
170: 00:02:00 (000000) 0x4 0x1 data (leadout)
__________________________________
what ioctl's report
get mcn : FAILED
disc status : data mode 1
multisession: 0
audio status: FAILED
__________________________________
try to find out what sort of CD this is
CD-ROM with iso9660 fs
iso9660: 1543 MB size, label `CDROM '

test005:~ # mount /dev/sr0 /mnt
mount: block device /dev/sr0 is write-protected, mounting read-only

VIO client partition devices

SVSA Physloc Client
Partition ID
--------------- --------------------------------------------
------------------
vhost2 U9133.55A.99999H-V1-C9 0x00000007

VTD test005rvg1
Status Available
LUN 0x8100000000000000
Backing device hdiskpower12
Physloc U787B.001.999999-P1-C4-T2-L32

VTD test005rvg2
Status Available
LUN 0x8200000000000000
Backing device hdiskpower13
Physloc U787B.001.999999-P1-C4-T2-L33

VTD vtopt0
Status Available
LUN 0x8300000000000000
Backing device
/var/vio/VMLibrary/IBM_Installation_Toolkit_51.iso
Physloc

VTD vtopt2
Status Available
LUN 0x8400000000000000
Backing device
/var/vio/VMLibrary/IBM_Installation_Toolkit_51.iso
Physloc


--
sbeaton
------------------------------------------------------------------------
sbeaton's Profile: http://forums.novell.com/member.php?userid=122604
View this thread: http://forums.novell.com/showthread.php?t=450705