As the title says, while installing SLES 11 SP2 from disc, I am getting several errors about incorrect checksums of certain packages (these are: sash, libtalloc, perl-Net-SSLeay, smartmontools, and nfs-client).

I generated a checksum from the disc and checked this against the one on the download page, and it still passes, so I definitely have a non-corrupted, most recent version of the ISO.

Any ideas on what may cause this error, and how to resolve it?

This install is autoyast-configured, and installing to a VMWare VM, if that makes any difference.