I fixed it. The PAM module has a auto home function that interacts with samba. To disable this function you have to set browseable = no in the global parameter. Set browseable = yes in the homes section.

If you set browseable = yes in the global section, it will display the username as the name of the folder.