I am trying to install via rpm or compile the source of OpenFOAM on my newly bought SLED and have some issues.

I worked a lot on Fedora previously and I miss a lot of development tools and libraries. I downloaded and added the "SLE-11-SDK-DVD-x86_64-GM-Media1" iso which is supposed to contain the development tools.

On the OpenFOAM wiki, i followed the "openSuse" instructions as they seemed to be the closest to my case (http://openfoamwiki.net/index.php/In...2.3.0/openSUSE).

My first problems aroused when trying to install the prerequired tools :
Code:
sudo zypper install -t pattern devel_C_C++
sudo zypper install cmake libqt4-devel qt4-x11-tools qt4-assistant-adp-devel gnuplot openmpi-devel boost-devel gmp-devel mpfr-devel libQtWebKit-devel
C and C++, qt4-assistant-adp-devel and qt4-x11-tools are not found.

While libqt4-devel-4.4.3-12.9.x86_64 (missing libqt4 = 4.4.3) libQtWebKit-devel-4.4.3-12.9.x86_64 (missing libQtWebKit4 = 4.4.3) cannot be installed due to missing libraries.

If I ignore the missing dependencies, OpenFOAM compilation fails.

Thanks for any help !