Upgrading a SLES 11 SP2 server to SLES 11 SP3 using zypper using these
docs:
https://www.suse.com/documentation/s..._sle11sp1.html

ran this:
zypper se -t product | grep -h -- "-migration" | cut -d'|' -f2

It returned both of these:
SUSE_SLES-SP2-migration
SUSE_SLES-SP3-migration

sync:~ # zypper in -t product SUSE_SLES-SP2-migration
Refreshing service 'nu_novell_com'.
Loading repository data...
Reading installed packages...
Resolving package dependencies...
2 Problems:
Problem: product:SUSE_SLES-11.2-1.538.x86_64 obsoletes
SUSE_SLES-SP2-migration provided by
product:SUSE_SLES-SP2-migration-11.1-1.6.x86_64
Problem: product:SUSE_SLES-11.2-1.538.x86_64 requires sles-release =
11.2-1.538, but this requirement cannot be provided

Problem: product:SUSE_SLES-11.2-1.538.x86_64 obsoletes
SUSE_SLES-SP2-migration provided by
product:SUSE_SLES-SP2-migration-11.1-1.6.x86_64
Solution 1: downgrade of product:SUSE_SLES-11.2-1.538.x86_64 to
product:SUSE_SLES-11.1-1.206.x86_64
Solution 2: do not install
product:SUSE_SLES-SP2-migration-11.1-1.6.x86_64

So I am wondering whether I really need SUSE_SLES-SP2-migration?
If I do need it, which Solution should I use?

Thanks!
Ken