SUSECON
Results 1 to 2 of 2

Thread: autoyast registration network error

Threaded View

  1. #1

    autoyast registration network error

    We are preparing our sles12 template, and encounter a problem during the autoyast automated installation "registration" step.

    Our setup:
    VMware Virtualisation
    autoint.xml autoyast installation
    installationmedium is .iso
    autoyast profile over a floppy mount
    network setup: static ipv4, with standard gateway + proxy für http/https and ftp.


    Configuration
    <proxy>
    <enabled config:type="boolean">true</enabled>
    <ftp_proxy>http://proxy.mydomain.com:3128/</ftp_proxy>
    <http_proxy>http://proxy.mydomain.com:3128/</http_proxy>
    <https_proxy>http://proxy.mydomain.com:3128/</https_proxy>
    <no_proxy>localhost, 127.0.0.1</no_proxy>
    <proxy_password/>
    <proxy_user/>
    </proxy>

    <networking>
    <setup_before_proposal config:type="boolean">true</setup_before_proposal>
    ...
    +static ipv4 network
    ...
    </networking>

    After the completion of installation, the machine is able to do the online registration manualy through yast -> online registration


    I have noticed that the Bash Shell Enviroment which i accessible after the Installation abort, does have network proxy issues.

    For that reason i added some proxy settings to /root/.curlrc and /etc/sysconfig/proxy.

    <pre-scripts config:type="list">
    <script>
    <filename>pre.sh</filename>
    <interpreter>shell</interpreter>
    <source><![CDATA[
    #!/bin/sh
    touch /root/.curlrc
    echo '--proxy "http://proxy2.mydomain.com:3128/"' >> /root/.curlrc

    echo "" > /etc/sysconfig/proxy
    echo 'PROXY_ENABLED="yes"' >> /etc/sysconfig/proxy
    echo 'HTTP_PROXY="http://proxy2.mydomain.com:3128"' >> /etc/sysconfig/proxy
    echo 'HTTPS_PROXY="http://proxy2.mydomain.com:3128"' >> /etc/sysconfig/proxy
    echo 'FTP_PROXY="http://proxy2.mydomain.com:3128"' >> /etc/sysconfig/proxy
    echo 'GOPHER_PROXY=""' >> /etc/sysconfig/proxy
    echo 'NO_PROXY="localhost, 127.0.0.1"' >> /etc/sysconfig/proxy
    ]]>
    </source>
    </script>
    </pre-scripts>

    But sadly that did not solve the connection error during registration.

    linuxrc was the last straw for me, but the following settings in autoint.xml, dont work yet:
    <install>
    <init>
    <info_file>
    <![CDATA[
    #
    # Don't remove the following line:
    # start_linuxrc_conf
    #
    Nameserver=<some IP>
    Netdevice=eth0
    NetConfig=static
    gateway=<some IP>
    hostip=<some IP>
    netmask=<some netmask>
    autoyast=floppy
    domain=mydomain.com
    hostname=<fqdn>
    textmode=0
    proxy=http://proxy2.mydomain.come:3128

    # end_linuxrc_conf
    # Do not remove the above comment
    #
    ]]>

    </info_file>
    </init>
    </install>

    Any Ideas that could lead me the way would be very much appreciated.
    Last edited by liebigt; 06-May-2015 at 08:22. Reason: blank ip and dns name

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •