after a lot of reading in several forums (not just the one linked here) and testing several key-mapping programs, i have been able to finally (& partially) solve this issue. the mute function, raise volume, lower volume now work!

the solution: i created the file $HOME/.Xmodmap and put inside the following information after investigating previously the key-codes for those multimedia buttons:

keycode 162 = XF86AudioPlay NoSymbol XF86AudioPlay NoSymbol XF86AudioPlay
keycode 164 = XF86AudioStop NoSymbol XF86AudioStop NoSymbol XF86AudioStop
keycode 144 = XF86AudioPrev NoSymbol XF86AudioPrev NoSymbol XF86AudioPrev
keycode 153 = XF86AudioNext NoSymbol XF86AudioNext NoSymbol XF86AudioNext
keycode 176 = XF86AudioRaiseVolume NoSymbol XF86AudioRaiseVolume NoSymbol XF86AudioRaiseVolume
keycode 174 = XF86AudioLowerVolume NoSymbol XF86AudioLowerVolume NoSymbol XF86AudioLowerVolume
keycode 160 = XF86AudioMute NoSymbol XF86AudioMute NoSymbol XF86AudioMute
then i logged out and logged in, and it worked as before!

now the second step (which is just for fun, not really important anymore) it's how to set up those remaining keys with xmms (the original xmms1).
i tried setting up the play/pause, next/previous track keys; however, i still haven't figured how to make them work.
however, this is not my concern anymore. all i wanted was the volume buttons.

this thread is now solved.