Hello Everyone,

I'm facing this really annoying problem after updating my SLES SP1 to SP2
Apparently everything went well when I did the update but now X (or gnome, I don't know for sure where the problem is) don't start and after boot process I only get the good old shell-mode

I've tried many things but nothing seems to work so decided to ask here

When the OS is finishing the loading I receive this messages

Starting service gdmstartproc: signal catched /usr/sbin/gdm: Segmentation Fault
Master Resource Control: Runlevel 5 has been reached
Failed Services in runlevel 5: esp mcelog xdm
Skipped services in runlevel 5: nfs

When i try to use startx (as root) i get this

Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Wed Nov 18 08:55:35 2015
(==) Using config file: "/etc/X11/xorg.conf"
(EE) Failed to load module "freetype" (module does not exist, 0)
(EE) MGA(0): [drm] Direct rendering only supported with G200/G400/G450/G550.
(EE) config/hal: NewInputDeviceRequest failed (8)
(EE) config/hal: NewInputDeviceRequest failed (8)
(EE) config/hal: NewInputDeviceRequest failed (8)
(EE) config/hal: NewInputDeviceRequest failed (8)
/etc/X11/xim: Checking whether an input method should be started.
/etc/X11/xim: user environment variable LANG=en_US.UTF-8
sourcing /etc/sysconfig/language to get the value of INPUT_METHOD
INPUT_METHOD is not set or empty (no user selected input method).
Trying to start a default input method for the locale en_US.UTF-8 ...
There is no default input method for the current locale.
Dummy input method "none" (do not use any fancy input method by default)
gnome-session[49496]: WARNING: No required applications specified
GNOME_KEYRING_SOCKET=/tmp/keyring-tS4KFa/socket
SSH_AUTH_SOCK=/tmp/keyring-tS4KFa/socket.ssh
GNOME_KEYRING_PID=49544
/usr/lib/gnome-settings-daemon/gnome-settings-daemon: symbol lookup error: /usr/lib64/gio/modules/libdconfsettings.so: undefined symbol: g_settings_backend_get_type
Exit: gpk_check_privileged_user returned FALSE
W: main.c: This program is not intended to be run as root (unless --system is specified).
Failed to play sound: Not available
process 49556: arguments to dbus_message_new_method_call() were incorrect, assertion "path != NULL" failed in file dbus-message.c line 1070.
This is normally a bug in some application using the D-Bus library.
D-Bus not built with -rdynamic so unable to print a backtrace
gnome-volume-control-applet: symbol lookup error: /usr/lib64/libpango-1.0.so.0: undefined symbol: g_malloc_n
gnome-terminal: symbol lookup error: /usr/lib64/libpango-1.0.so.0: undefined symbol: g_malloc_n
Traceback (most recent call last):
File "/usr/lib64/python2.6/site-packages/system-config-printer/applet.py", line 31, in <module>
import pynotify
File "/usr/lib64/python2.6/site-packages/gtk-2.0/pynotify/__init__.py", line 1, in <module>
from _pynotify import *
ImportError: /usr/lib64/libpango-1.0.so.0: undefined symbol: g_realloc_n
Then I tried to run sax2 to reconfigure but I just get this:

SaX: your current configuration will not be read in

SaX: no graphics card(s) found at /usr/share/sax/init.pl line 157.
xrandr returns just this

Can't open display
I tried to comment the "Load "freetype"" line in xorg.conf but that did nothing (just the line talking about this error disappeared when I tried to run startx again)

my videocard is a Matrox mga 200
(From xorg.conf)

Section "Device"
BoardName "G200 eW"
Driver "mga"
Identifier "Device[0]"
Screen 0
VendorName "Matrox"
EndSection

Serverflag and Modules that are loaded in xorg.conf

Section "ServerFlags"
# Uncomment the following option to reenable kbd/mouse driver input sections.
# Otherwise evdev driver is used.
#Option "AutoAddDevices" "off"
Option "AllowMouseOpenFail" "on"
Option "ZapWarning" "on"
EndSection

Section "Module"
Load "freetype"
Load "dbe"
Load "dri"
Load "glx"
Load "extmod"
EndSection


If any information is missing just tell me.
I've digged a lot and nothing seems to work...I'm thinking about installing KDE but I fear that it could just make things worse...

Sorry for long post (I tried to make it as organized as possible) and really thanks for your time guys