Hi All,

As a part of study, i am setting up SUSE Openstack Cloud 6 on Virtual Box. The SUSE administration server installation went fine. Now i need to add a node to it.

When a new node is added, it is properly getting PXE booted but failing at NTP synchronization stage. Due to that, the newly booted node is not getting registered with crowbar and not shown in the UI.

Log at SLES Admin node : /var/log/crowbar/sledgehammer/d08-00-27-eb-2e-85.localcloud.transcript

DHCP_STATE=discovery^M
19 Apr 10:55:15 ntpdate[719]: no server suitable for synchronization found
Waiting for NTP server
19 Apr 10:55:22 ntpdate[721]: no server suitable for synchronization found
Waiting for NTP server
19 Apr 10:55:29 ntpdate[723]: no server suitable for synchronization found
Waiting for NTP server
19 Apr 10:55:36 ntpdate[726]: no server suitable for synchronization found
Waiting for NTP server
19 Apr 10:55:43 ntpdate[728]: no server suitable for synchronization found

TCP Dump at admin server

16:51:43.768103 IP (tos 0x0, ttl 64, id 27812, offset 0, flags [DF], proto UDP (17), length 76)
192.168.124.28.ntp > sles-admin6.localcloud.ntp: [udp sum ok] NTPv4, length 48
Client, Leap indicator: clock unsynchronized (192), Stratum 0 (unspecified), poll 3 (8s), precision -6
Root Delay: 1.000000, Root dispersion: 1.000000, Reference-ID: (unspec)
Reference Timestamp: 0.000000000
Originator Timestamp: 0.000000000
Receive Timestamp: 0.000000000
Transmit Timestamp: 3670053723.146002963 (2016/04/19 16:52:03)
Originator - Receive Timestamp: 0.000000000
Originator - Transmit Timestamp: 3670053723.146002963 (2016/04/19 16:52:03)
16:51:43.768312 IP (tos 0xb8, ttl 64, id 4838, offset 0, flags [DF], proto UDP (17), length 76)
sles-admin6.localcloud.ntp > 192.168.124.28.ntp: [udp sum ok] NTPv4, length 48
Server, Leap indicator: clock unsynchronized (192), Stratum 0 (unspecified), poll 3 (8s), precision -22
Root Delay: 0.000000, Root dispersion: 0.067794, Reference-ID: (unspec)
Reference Timestamp: 0.000000000
Originator Timestamp: 3670053723.146002963 (2016/04/19 16:52:03)
Receive Timestamp: 3670053703.768103957 (2016/04/19 16:51:43)
Transmit Timestamp: 3670053703.768283903 (2016/04/19 16:51:43)
Originator - Receive Timestamp: -19.377898991
Originator - Transmit Timestamp: -19.377719044

May i know how to overcome this issue? Since the networks configurations are handled by crowbar, the SLES Admin server cannot access internet.

Thanks in advance!